S9+ They say there is an update to Q but

I started going the “flash individual files” path (but I’ll probably follow your advice finally…), and comparing the device PIT content and the files (.img and .bin) available in the stock rom, I see corresponding filenames / partitions:

–BOOTLOADER sboot.bin --KEYSTORAGE keystorage.bin --BOOT boot.img --CACHE cache.img --CM cm.bin --RECOVERY recovery.img --RADIO modem.bin --DQMDBG dqmdbg.img --SYSTEM system.img --VENDOR vendor.img --ODM odm.img --HIDDEN hidden.img --OMR omr.img --USERDATA userdata.im

But I also see several partitions holding files that are absent from the stock ROM:

Partition Name: ECT / Flash Filename: ect.bin
Partition Name: MD5HDR / Flash Filename: md5.img
Partition Name: EFS / Flash Filename: efs.img
Partition Name: PARAM / Flash Filename: param.bin
Partition Name: UP_PARAM / Flash Filename: up_param.bin
Partition Name: DTB / Flash Filename: dtb.img
Partition Name: DTBO / Flash Filename: dtbo.img
Partition Name: NAD_REFER / Flash Filename: nad_refer.bin
Partition Name: STEADY / Flash Filename: steady.bin
Partition Name: CP_DEBUG / Flash Filename: modem_debug.bin

Is this expected, and what are these partitions for ? (just trying to understand before bricking the phone with too much hurry !!)

@alci , my impression is: You are skating on thin ice!
Samsung’s Stock Android 10 comes as a packed file. Depending on the download source, as a single file with the file extension *.zip or *.tar in which there is then either a single file with the extension or as 4 or 5 files included with the extension .tar.md5

AP (System & Recovery)
BL (Bootloader)
CP (Modem / Radio)
CSC (Country / Region / Operator)
HOME CSC (Country / Region / Operator) 

The first four *.tar.md5 files are conveniently installed with Odin/Heimdall without the user having to worry about which file to flash where. The procedure presented here is the much riskier method and is an invitation to brick your device. If you know exactly what you are doing, the situation looks different again. Do it right!

As you might have guessed, I really don’t know exactly what I’m doing !
So I’ll stick to the way you advice !
I was just trying to postpone the moment where the dice is cast… and to understand a bit more.

So, let go flash the *.tar.md5 :slight_smile:
I’ll keep you informed…

Yes, a few words of feedback are always welcome to me and much preferable to wordless “Heart”

1 Like

Good evening,

Unfortunately I have some issues with the upgrade as well.
My Glaxy S9+ was flashed to /e/ with the Easy Installer. When I wanted to update to O the option “OEM Unlock” was not visible. I tried all recommended fixes, but nothing worked.

Next things I did, smart or not (probably the last):

I updated TWRP to the latest version (which succeeded)
I flashed the /e/ recovery image: recovery-e-0.13-q-2021012097133-dev-star2lte.img (succeeded too)
I tried to flash e-0.13-q-2021012097133-dev-star2lte.zip by using TWRP. Unfortunately, my phone is in a bootloop when I restart it, I get the error:

Vendor image on device is NOT compatible
Expected Android 10 vendor

Does this mean I have to upgrade to the latest Samsung Firmware? How do I do that, since I can’t find the exact model number of my phone in recovery.


Yeah, that’s exactly what it means!

Read all current threads, e.g. Galaxy S9 'starlte’ and Galaxy S9+ ‘star2lte’ to find the solution to your problem. Under no circumstances should you currently use the /e/asy installer. It does not load the latest /e/ ROM ‘Q’ at the moment.

Ok, I finally got the phone to boot with stock Samsung ROM… I had to find a Windows box, find version 3.14.1 of Odin (as neither Heimdall (on Linux) nor Odin 3.10.1 (on Windows) worked*).
Now… how do I get back to /e/OS (Q)…!?
Is the easy-installer v0.11.2-beta compatible with Android Q, or will it somehow try to downgrade and eventually break the phone ? If it iss not compatible, is there an howto I should follow ?

Thanks again for your support

  • heimdall failed with ERROR: Failed to receive session end confirmation!
  • Odin 3.10 was just stuck with no message

Oh… I just read your last comment right now ! So no easy_installer, I’ll read the relevant thread for S9+ star2lte.

Excellent. All signs are now set for success!

  1. First, you unlock the OEM Unlock in StockROM 10 of the S9+. Without it, you will not be able to continue.

  2. Then flash a custom recovery: eRovery or TWRP 3.5.0_9-0.

  3. Finally, install the e-0.13-q*.zip with the help of this custom recovery. A reliable help is here.

Hurray ! Back to /e/, with e-0.13-q !

Many thanks

How do you like it so far?

:+1: Do not forget to set more privacy!

Network and Internet

DNS Configuration
Use network DNS - disable -

Set DNS Use
Enter DNS IP

Back to Network and Internet

Data Saver, VPN, Private DNS

Private DNS
Selcet private DNS mode
[x] Private DNS provider hostname
anycast.censurfridns.dk [for example]


Well, for now it’s not son different from e 0.13 in its aosp 8 version
Main difference for me is that text and icons are very small… I had to set accessibility options to make it readable :slight_smile:

But I still have to explore it a bit, obviously !

1 Like

i did that, thanks. Notice however that Private DNS option does not play well with TrackerControl. I had to disable it.

Yeah, TrackerControl is a difficult tool and the handling of it needs to be practiced, this means as much as: every medal has two sides.

OK finally got it to boot into /e/ OS again…

Build Number: e_star2lte-userdebug 8.1.0 OPM7.181205.001 ebef99465c dev-keys
Baseband: G965FXXUCFTJ1

Thanks for the help

Which version of the /e/OS is this v0.13 or v0.14

Look in the filename. -o- for Oreo vs -q- for Q.


So one problem was Odin was version 3.12 needed 3.13 or higher for the program to recognize the new compression Samsung uses on the firmware files apparently. My bad, website I downloaded Odin from said it was the latest version, dag what a bunch of time wasted with that problem…

Have Andoid 10 installed! Yea! Now off to -q- version

Hello SuzieQ,

Thanks for your answer, I didn’t have time to look at my Samsung earlier.

I have the latest TWRP and the recovery-e-0.13-q-2021012097133-dev-star2lte.img recovery.

I have installed ADB, can I sideload the Oreo version to go back to the previous Android version? Do you know where I can find the download? On the site, I can only find the Q-version.

I am also downloading the Samsung 10 firmware. I bought a European model, can I just select the country where I live, or does it has to match exactly with the current firmware?

Probably stupid question, but can the firmware be installed with ADB? I also have Heimdall on my Linux, can that be used for installing the firmware, while the phone is in download mode?

I have to choose my best option to get out of this recovery situation (back to O, or forward to Q).