Samsung A5 2017 - reboots instead of shutting down

I just installed /e/ on a Samsung A5 2017 - the install went fine, no issues at all during the process. I know have two issues and the first may be contributing the the second. If I select Power-Off, it goes through the motions, but only ends up rebooting the phone.

I tried to install the sim card from my old phone, but it doesn’t seem to see it (and I’m not sure if that’s because of this inability to properly shutdown issue). Suggestions?

Did you do the flashing from the beginning with the SIM card inserted - or - was the SIM card only inserted after the complete installation of /e/ OS?

Two approaches:

  1. Immediately after the installation of TWRP the device should be switched off completely.

  2. After installing /e/ OS and inserting the SM card, reset to factory settings to see if the SIM card is recognized by the /e/ OS system.

Feedback desired.

I only inserted the SIM after the OS install. I never tried it in the native Android that the phone came with (so, there is also the possibility that the phone has a hardware issue).

  1. I don’t think I switched it off after TWRP, rather, rebooted.

  2. Never tried a factory reset from within /e/ - will have to try that.

I decided to see if putting Android back on the phone would yield any different results, but Odin was useless. I have only three machines left running Windows anymore - tried two of them. One couldn’t even see the phone, the other couldn’t seem to do more than a second of transfer before it failed. So I was unable to get Android back on it because no one seems to have an Android image I can just use the adb sideload with.

I installed LinageOS instead, just to try another OS - still didn’t see the SIM. I’m out of town at the moment - will have to try what you mention when I get back.

So would you suggest this order of operations when I get back:

  1. boot into TWRP, shut off device completely.
  2. Install SIM at this point?
  3. Boot back into TWRP - sideload /e/
  4. Boot into /e/ see if SIM card shows up, if not…
  5. Factory reset form within /e/?

#3 @Dakiraun

I always do this (observe order)

  1. Copy all necessary files to an external microSD card. SIM card not yet in the device (Note: This does not mean that the SIM card must not be inserted from the beginning. It is only my procedure.)

  2. Install TWRP for twrp-3.3.1-1-a5y17lte via Samsung Odin. Important: Disable “Auto Reboot” in the ODIN options = uncheck].
    After TWRP Recovery has been installed, switch off the device completely - wait until all lights on the device have gone out.

  3. Reboot TWRP Recovery and flash the /e/ OS build via "clean Install " ~ “Advanced Wipe”.

    Use TWRP INSTALL e-0.7-n-2019* instead of TWRP sideload. Then back to the TWRP menu and again “Wipe cache/dalvik” …

  4. Boot the /e/ OS and test if the installation was successful.

  5. If the SIM card was not inserted from the beginning - insert the SIM card now. To be on the safe side, reboot the system.

  6. If the SIM card is not recognized by the system: Reset the /e/ OS system to factory settings and retest …

Side note: This procedure was successful when my SIM card was not recognized by the device after flashing a new bootloader/baseband firmware.

For your information, your first issue about the no-shutdown was reported here one year ago:

Thanks for the info.

Well, it is indeed an old known Samsung devices problem.

“reboots instead of shutting down” also happened to me in the beginning.

With the method described in Post #4 I mastered the “problem” and since then I have not been confronted with it anymore, although I have already flashed several different Samsung devices.

I think you can add this kind of Information directly as a comment in the gitlab issue. It could help the developpers team.

Unfortunately, there is no guarantee of functioning, because with all industrial production, not every device in a model range is identical to the other.

I would be happy if you could solve your problem with my solution box first.

My concern with this method is using Odin. I run Linux on all my systems - I only have Windows around anymore on older machines, and Odin seemed capable of only pushing 40M or smaller files to the phone before the communication would fail. I used heimdall to load TWRP instead.

I could try the microSD card thing though for the Install method instead of sideload.

At the moment I’m out of town, so this will all be stuff I’ll have to try once back home and get some time to tinker. Thanks for the suggestions - I’ll let you know how it turns out.

Thanks - hopefully I can resolve it with archie’s method. Interesting thing to know is that when I installed LinageOS, the phone did shutdown properly - it was only /e/ that had the issue.

That is indeed interesting to know. I just wonder why this information is only now being mentioned.

Could just be circumstance. When /e/ wasn’t working, I tried (as I would think others would) to put Android back on via Odin, but since Odin didn’t work on 2 of the 3 Windows machines I still have kicking around, I wasn’t able to do that, leaving my only other option as trying out LineageOS.

Yes, I understand that foresight. But for someone like me who wants to help another user, it is important to know what was done until the time of the error (“reboots instead of shutting down”). If important information drips in little by little, trying to help is unnecessarily protracted.

I already worked with four versions of Samsung Odin3: 3.07, 3.09, 3.10.6, and 3.13.3. All of them did their work without a hitch.

  • Before using Odin you must install the Samsung Android USB Driver for Windows on your PC. Otherwise Odin won’t recognize the phone.

Your statement that Odin3 didn’t work on your computers doesn’t give you any idea why Odin didn’t work correctly.

  • Which error messages were displayed?

  • Am I right in assuming that you flashed LineageOS 16.0 (base Android 9-Pie) - and now have problems with /e/ OS dev (7-Nougat) e-0.7-n-2019-a5y17lte?

Alrighty - update on things. First, I have resolved the Odin issue which I discovered to be two-fold. First, one of the images I had gotten from Sammobile seems to be invalid and causes Odin to error out. Second, I got some more recent Samsung drivers than those I had found previously which have improved support.

So… here are the things I did in order to test things out:

  1. I used Odin to return to the phone to Android 8.0 and the stock Samsung bootloader and rocovery partitions
  2. Tested to confirm it saw the SIM card - it did, all worked fine.
  3. Used the method you recommended to reinstall TWRP (no issues encountered)
  4. Used your recommended method to install the latest E build (no issues encountered)
  5. Booted into OS - SIM card was not detected
  6. Did a factory reset, rebooted
  7. SIM card still not detected

So, it appears the results are no different in the end. Both E and LineageOS appear to be lacking something that allows the phone to see/use the SIM.

Now, even with Android 8.0, I noticed the phone rarely shuts off properly - it just reboots, so that could be a legitimate hardware glitch. At this rate, since the phone is a new purchase, I may return it as glitchy and try switching to a different mode, like an LG G5. Thoughts?

My first thought was: WoW, good systematic work. Bravo!

My second thought was: Damn! - SIM card is still not recognized. Is it possible that the baseband firmware gets lost when flashing /e/ OS or LOS 16.0?

My third thought was, when I had read this …

Now, even with Android 8.0, I noticed the phone rarely shuts off properly - it just reboots, so that could be a legitimate hardware glitch.

… this device behavior is no excuse that the SIM card is not recognized with mobile /e/ OS or LOS, but it is absulut no normal behavior. This must not be the case.

One last thought before going to sleep:

4/ Mobile network - APNs : Reset APN settings to default values.

5/ Maybe it will help to insert another SIM card temporarily.

Heh - thank you. I am a Network Engineer and Security analyst on the core Network Infrastructure team at a university, so I’m used to a taking a methodical approach to troubleshooting - core switches, routers and, firewalls and so on can be just as odd with OS upgrades and firmware flashes. :stuck_out_tongue:

Now, working with phones at this level is something I’m new at. What do you mean by the baseband firmware?

I did think along similar lines that something is getting lost - just not sure how to zero in on what. Given that Android, E, and LOS are all derived from Linux, I’m guessing there is some sort of module added in the stock Android that is missing for the others (if it even works that way - just going with what I know). Thoughts?

#4 - can’t as APN area is greyed out when it doesn’t see the SIM.

#5 - also can’t because wifey is using only other phone, and I value my life too much to risk asking for it.

I did try using her SIM a few days ago though during the initial troubleshooting phase and it didn’t work either.

1 Like

The “baseband” is actually the wireless modem for mobile radio. The modem firmware aka baseband firmware is the software responsible for the cell activities within the entire Samsung firmware. Its tasks include harmonizing antenna reception to cell, enabling communication with other devices such as Blue-Tooth, Wi-Fi and GPS.

Unfortunately there is also official baseband firmware available which is not suitable for custom Rom’s.

An example from my LG G3 d855: One of the last official StockROM Android 6.x v30B (13-00106) = doesn’t work with custom Rom.

Official StockROM Android 5.0 v21C (13.2-0000002) = works and is recommended for android 5.x and higher custom ROMs).

Another experience on my part with a Galaxy S5 SM-G900F see posting #7 Post Baseband updates?

What is the baseband code of the baseband firmware used on your SM-A520F?

It shows “Unknown” under baseband in my phone. So… where does one get this from and how come that’s not part of the /e/ OS when you install it?