Samsung Galaxy A3 restarts when connected to WLAN

Okay , now I understand.
Nevermind. Thank you for your help!
I´m not that frustrated as it seems :smiley:

Secretly, I was hoping you’d say, for example, no matter what happens - let’s try a more radical step ;o)

On the other hand, of course, understand that you don’t want to expose your phone to the danger of making it uncontrollable. Flashing, even with original Stock ROM firmware, can be dangerous.

As we know, even an OTA update can render a device inoperable, no matter if an Android Phone or a Windows PC.

Thanks for that information. I installed it last night and have a working phone at last! I managed to get rid of the google browser and install Yalp, Fdroid signal protonmail etc. without google play. (I am just a phone user with no software skills). have a long way to go…

/e/ is not a rough idea. Without a doubt, it takes visions and a big goal to develop innovative products and solutions. Otherwise standstill prevails.

/e/ has achieved a lot in 1 1/2 years. A digital /e/ ecosystem will find more followers than LineageOS and LineageOS-for-mircoG combined.

You are right. I really hope it all comes together, it is a perfect ethos.

Anyone with the a3xelte device ?
We built a test build of /e/OS Pie for the device and it seems to have resolved the issue.

You can pick up the build here in case you want to test it

Pl note the device code name is a3xelte

1 Like

/e/OS 9-Pie - What at first looks like a simple OS upgrade, turns out to be the universal problem solver at a closer look.

1 Like

i had precisely the same problem and this Pie build solved it for me

Thanks a lot, this fixed the reboot problem for my a3xelte device.
When will the fix be in the official build?

/e/ documentation → Samsung Galaxy A3 (2016 Exynos) SM-A310F “a3xeltexx”
/e/ ROM latest dev build e-0.7-o-2020021240990-dev-a3xeltexx
TeamWin - TWRP Code Name: a3xelte

02/13/2020 - Exactly the same bug …

/e/ OS ROM build by_Manoj doesn’t show this peculiarity. Thank you @Manoj.

At least one question remains open: Why has such a serious bug not been fixed by the /e/OS Build Team until today? At least 10 months have passed since it was announced …

The simple reason is we do not have expertise in resolving hardware related issues in the dev team. Issues which are software related we can fix but ones related to hardware misbehaving have not been our strong point.

It is perfectly understandable that the /e/OS Build Team cannot fix hardware problems.

To call this failure a hardware bug is, if you will pardon my saying so, simply unjustified, @Manoj.

Your test /e/ OS ROM doesn’t show this bug. You didn’t change anything on the hardware, but built a software exclusively with your knowledge and skills. And the bug is already eliminated …

The fix for the issue was in the Pie branch. To port it to the nougat builds would have taken a level of expertise which we lack or did not have the resources to invest in. That was why it never made it through. Now this issue may be resolved in the a3xelte but is still there in some other versions which just do not build in Pie. May be because they do not have working pie versions. To fix the issue in those Samsung devices we need some additional skills.

Well @Manoj, we want to be in the best interest of /e/volution and hope that there will be many improvements in the next months due to the migration to /e/ OS 9-Pie and /e/ OS 10 (Q).

Yesterday I tried to install /e/ on a Samsung A3, the last e-0.7-o-2020021240990-dev-a3xeltexx.
And like other users trying this device, it finished during the first startup to a loop when we started the WLAN.
SO I tried the patch OS ROM .
But I tried with a fresh install, and formatted the partition.
TWRP installed the ROM correctly…
but the first boot finished with the e . dancing on a black background… undefinitively … (at least during 10 minutes)
I tried several time, with the same result.
So I reinstalled the e-0.7-o-2020021240990-dev-a3xeltexx.
and I red some more pages on this forum (english, or french pages)

I tried again. If some people can do it, why not me on my phone…
and I tried without wiping the partition, so I presume TWRP installed the test version like an update over the dev version, without modify the config.
reboot… and /e/ started correctly, directly on the desktop. (without the setup pages)
WLAN is ok. surf seems ok
Now I can try /e/… and have fun.

Have a nice day / Bonne journée

1 Like


I just did my first try in Android flash ROM installation.
I did this first attempt with a Samsung Galaxy A3 (2016 Exynos) out of order because of a faulty battery.
With a new battery in place, I followed the instructions explained HERE

Like I said it was my first attempt, so it worked at the 2nd or 3rd try but it worked ! I used for that the last ROM downloadable :
It worked well, and I was discovering the /e/ universe using wifi to download apps, looking the functionalities, etc…
And suddenly, the phone restarted and entered in a bootloop until I cut the WIFI router.

After reading all the messages on this post I tryed to install the patch ROM given by @Manoj (
I didn’t know how to proceed so I tryed to install directly with an adb sideload command without wiping the phone. It didn’t work. Re-installed the first one and try to install the patch like an update with the TWRP Install fonction (after copying the ROM on the phone). It didn’t work either.
At last I wiped all my phone and installed directly the patch and it finally worked.

I hope the official version will include the correction soon.
And when it’s done, will I have to re-flash my phone, or will it be a simple update ?

Thank you for all your work !

1 Like

I also have the boot-loop when I enable WLAN :frowning: If I disable the router, the phone starts normally.
Now I’m new on /e/ and I had bought an used phone specifically for this “ungoogled OS”.
If I had known that this bug existed, my decision would be different.
Nevermind, I could not find out if a bugfix exist meanwhile.
The above linked “Pie” test image is no more available.
Are still working on a solution to the problem?
Thank you very much indeed!

1 Like
after installation do a rom update for a later version
Works fine for me
1 Like

I’ve successfully build an image from e-0.12.3-p-UNOFFICIAL-a3xelte with docker. The e-0.13 and e-0.14 versions compile successfully, but the phone went in bootloop.
I cannot use the official oreo version because of the wifi reboot issue.
Can someone help me to find out what the issue is with the 0.13/0.14 versions?

i can share the Pie ttest image if people still need it
The official Q update is expected for february