Samsung Galaxy A5 (2017) - Upgrade to R failed / rollback to Q error

Hi everyone,

I have tried to upgrade my Samsung Galaxy A5 2017 (a5y17lte) from e-0.18-q-20210827132307-dev to e-0.18-r-20210903133573-dev, using TWRP, but it didn’t ended very well and I’m quite stuck right now.

Here is what I did :

  • No backup because I’m too lazy (and all my previous updates / upgrades (P to Q) went well, with no data loss)

  • Downloaded the file

  • Tried to sideload it, using sudo adb reboot sideload then sudo adb sideload
    → No error message, so once completed I clicked on System Reboot, and got a boot problem : animated /e/ os logo for a while, then automatic reboot to recovery
    Note : using this method, I never was asked to wipe cache / Dalvik…don’t know if it is important to mention

  • Facing this issue, I tried once again to sideload the .zip file with TWRP, this time using the sideload function in the “advanced” menu (and not reboot directly to sideload). I had the possibility to wipe cache / Dalvik this time, so I selected both.
    → Same result : no error message, but the system doesn’t boot, and finally it auto-reboots to recovery after a while

  • Last try, using the “Install” menu and installing the .zip file from the sdcard
    → Still no error message, rebooted to system, and this time I was just stuck to the animated /e/ os logo. I waited for a solid 10 minutes and nothing happened, so I choose to reboot to recovery manually.

  • I then wanted to roll back to Q, so I downloaded the file and sideloaded it using the first mentioned method

Now, I’m able to boot the phone and enter the PIN code to unlock my SIM card, but when I unlock my screen, I have a launcher error “Lawnchair 2 keeps stopping” popping in a loop, and a pop-up to choose which launcher to use.
I tried to choose Bliss Launcher since it didn’t work with Launwchair, and now I have the same issue but the pop-up doesn’t show up anymore, so I can’t change it back to Launwchair.

So that’s the situation for now, I’m unable to use my phone (which is, of course, my daily driver), and I’m looking for your kind help to solve my issue :grinning_face_with_smiling_eyes:

Note that my recent apps (last used before the upgrade) are still open, and I can access it through the “recent apps menu”, so it seems my data are still present on my device, and I’m hoping to save it as much as I can…

What I consider to try :

  1. Install a new launcher using adb, uninstall lauwnchair with adb, reinstall it…and try to get a functionnal UI somehow. If this works, I will make a proper backup using TWRP, and maybe try to upgrade to R again (using another method ? what can I do differently ?)

  2. If it doesn’t work, try to save every data I can with adb pull ... since I can’t access my data through the launcher, then factory reset the phone, and try to install

  3. If R doesn’t work on a clean factory reset neither, reinstall Q on a fresh factory reset, and re-build my actual configuration (and make a backup !!)

What do you think about my situation ? Any idea why the upgrade didn’t work as expected ? Any tips to make a launcher work again ? What would you do in my place ?

Thanks in advance for your help !

Thanks @piero for your answer, I should have read all the posts before attempting my upgrade…

Anyway, for those interested, I tried to uninstall / reinstall several launchers with the same result, so at one point I just rebooted to recovery and made a factory reset on the current version (0.18-q-dev), which worked but of course I lost all my apps and data.

Since my phone seemed to work normally, I installed once again the new version 0.18-r-dev, but got the same problem on boot than before.
I then rebooted to recovery (btw, I installed the new e-recovery…quite nice !) and factory reset with the new version installed → success !

So now my phone is working just fine with Android R, but I lost everything in the process.
Conclusion : read the link from Piero !

Have a nice day everyone :wink:

Does the new /e/ recovery support backup and restore like TWRP?

Nop, the /e/ recovery only contains the following options (for now at least) :

  • Reboot system now
  • Apply update (= sideload, that I used to upgrade to R)
  • Factory reset
  • Advanced : Reboot to bootloader, Reboot to recovery, Mount/unomunt system, View recovery logs, Enable ADB, Power off

It is minimalist, but to be honest I never used TWRP backup and restore…even if I should apparently !
When installing a new version of /e/ OS using the /e/ recovery, you can choose to update the recovery at every OS update… so I assume that new functionalities should be added over time