Samsung Galaxy S8: bootloop after blocked in easy-install, impossible to recover

Hello, I was trying to install eOS on a Samsung Galaxy S8, everything went smooth till the reboot in twrp: I’ve read elsewhere in the forum that I probably missed the quick move needed. First time I went through the process, it just reset the phone to factory default so I started again, but this time it stopped again and when I tried to turn on the phone it just kept on a loop with the first Samsung screen over and over, I tried to access the recovery mode, swipe and reset factory defaults, but on reboot it always goes in loop again. I tried to see if the easy install process would work with the device (in dowload mode, recovery mode…) but nothing happened. I also tried heimdall but it seem it can’t communicate with the phone.

Do you have any idea about how can I get the access to the phone and keep going on with the installation process?

Thank you.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Now I’m still stuck but slightly differently, in the easy installer I stopped at the wipe and reboot and doesn’t move on, the phone is stuck in team win screen, no way to keep going on with the installation. When it is the moment to reboot it says “No OS installed! Are you sure you wish to power off?”. So it looks like a new loop…

The thing to do now is look for the manual instructions for your device.

Easy Installer has done the difficult part.

As you say, the bootloop is just “no os to boot”.

Take some time to read the manual instructions, picking up at the point where you install with TWRP.


hi, i am having the same issue. i am using Samsung S8 (either model sm-g950f or sm-g950fd, i cannot remember, but ii did check, it is one of them).
i use easy-install and than it got hang after i did the format data, back back back(3x) and reboot. it just restart in the recovery mode. so i try the Install via command line.
second: Installing /e/ from recovery
i did this: adb reboot recovery, and the phone restart into recovery. i went to wipe and format data. went to advanced Wipe and selected system, however due to issue the phone touch screen, cache is not selected and than ‘Swipe to Wipe’.
when i do push and install using adb push </home/lucan/Downloads/> /sdcard/
i got something like this: “bash: /sdcard/: Is a directory”.
than i do adb push </home/lucan/Downloads/> /sdcard
i got something like this: “bash: /sdcard: Permission denied”.
lastly, i copy the zip file into a sdcard, insert into the phone, went to recovery mode tap install, install the os and reboot. Finally i can see the e logo, however after around 30 second, it went back to recovery mode.
i should i do next, any advise?

Firstly, just go back to recovery and ask for Factory reset.

I think that you are telling the story of your attempt at the “manual install” in a sort of narrative style, rather than the specific commands you used.

However the actual commands must be done with exact copy of the required commands!

The method where you simply copy the /e/ image to SD card with familiar tools may be the most reliable.


if you have to go back, you should include wiping all the partitions exactly as defined by the instructions.

when i done with exact copy of the required commands, which is “adb push </e/ zip package> /sdcard/”. I got something like this: “no such directory” or “no file found”.
that why i replace the </e/ zip package> with </home/lucan/Downloads/> because that is where the zip file is.
Btw, i did try to Factory reset, is just went back to recover mode, restart the phone serveral times? did that too. the phone start with the Samsung S8 screen change to the e logo screen, wait for a while went back to recovery. any others advise? thanks for reply. :kissing_heart:

Ah, I see … your install instructions are here; you correctly quote the passage:

  1. Push and install the /e/ .zip package:
    adb push </e/ zip package> /sdcard/
    adb shell twrp install /sdcard/</e/ zip package>
    adb shell rm /sdcard/</e/ zip package>

It is a convention that the content within < angle brackets > has to be filled in by the user, but excluding the angle brackets themselves. That literal content will produce exactly the result you got. My apologies that I did not spot and mention this in my first reply. :slight_smile:

Thanks for testing the Factory reset option – always worth a try.

I would expect that you could proceed as

The method where you simply copy the /e/ image to SD card with familiar tools may be the most reliable.

The “missing” wipe cache might have caused the issue.

I am not sure if you are using Windows (it does not matter at this point) but this tutorial may help demonstrate your options with TWRP, if this is unfamiliar to you.

Pick up the following tutorial at

8) Install /e/ with TWRP

[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

i am using Zorin OS. thanks for the reply. i will try it again, once i have the chance. btw, my phone doesn’t has a sdcard in place. do i need to insert a sdcard before i do the adb push?
adb push </e/ zip package> /sdcard/
the above code means to push the zip file to a sdcard right? if there isn’t any sdcard in the phone, the zip file cannot be push?

As usual you have choices … I suggested an external SD card just because that means one can use familiar copying tools and not clutter the device itself with a big file. However …

No … the internal storage of the device is /sdcard!

You might explore your own device using as a guide

As a little demo (forgive me if this is obvious) I set up an adb shell on my device (a3xelte) and ls for list.

iain@laptop:~$ cd platform-tools
iain@laptop:~/platform-tools$ ./adb devices
List of devices attached
52xxxxxxx53	device

iain@laptop:~/platform-tools$ ./adb shell
a3xeltexx:/ $ pwd

a3xeltexx:/ $ ls
acct bin        cache   config data          dev lost+found odm proc    product_services sbin   sepolicy sys    vendor 
apex bugreports charger d      debug_ramdisk etc mnt        oem product res              sdcard storage  system 
1|a3xeltexx:/ $ cd sdcard
a3xeltexx:/sdcard $ ls
Alarms Android DCIM Documents Download Movies Music Notifications Pictures Podcasts QKSMS Ringtones SMSBackupRestore

So I can recognise /sdcard as my internal storage.