Samsung - Galaxy Tab S5e (Wi-Fi) - gts4lvwifi - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

I just flashed a used Tab S5e and the docs here were sorely lacking. The documentation doesn’t mentioned odin / heimdall flashing tools at all. This device doesn’t support fastboot from what I can tell, and thats what the docs recommend. It seems like it needs to be re based on the lineageOS docs here.

I tried getting heimdall to work instead but had to use Odin.

Additionally I discovered that Samsung mysteriously hides the “OEM Unlock” option in the developer options for seven days. I was able to use method one here to restore it:

1 Like

Thanks for the inputs… We will update the documentation accordingly. The fastboot references in Samsung devices install and upgrade guides are to be removed.

That is the way we plan to do it. Maintainers are asked to check the guides when they are released and let us know in case there are any changes required. The problem comes where devices do not have maintainers or testers which is why we started these Documentation Suggestion sections where users can let us know what modifications need to be made.


Still No mention here about flashing a modified vbmeta.img (proposed by the twrp team) before flashing TWRP (as advised on LOS wiki for Galaxy Tab s5e)

Thanks for pointing that out @piero will have the missing section for the gts4lvwifi added.


I successfully migrated to /e/ on my S5e wifi.
Yet I used the S binaries (recovery and /e/) as indicated in the doc Install /e/OS on a Samsung Galaxy Tab S5e (Wi-Fi) - “gts4lvwifi”
The problem is that an updated S5e runs an Android 11 (R version), at least at 2022-11-20. Maybe will S5e never be migrated to Android 12?

I’ve been told that normally this R and S mixing is totally not recommanded! (I did that because it was not aware that R and S mean “11” and “12” !!! :wink: )

It ended well for me, but should a “caution” be added in the doc?

Unfortunately it seems I just managed to break my device (Galaxy Tab S5e Wifi). The reason I think was that I downloaded and flashed the vbmetar.tar File to the device, as the docu suggests “Download this VBMeta image .tar file.”. Afterwards the tablet kept booting in the TeamWin application. I also tried flushing the device with the custom S5e tar from the TeamWin website, but Odin just closed without any errors on my Windows machine. Because I could not work with Odin, I tried following these instructions:
Unfortunately after the installation /e/ OS did not start, which is why I tried to recover from a previously created backup. Since then, the device just keeps restarting and never stops. All buttons do not respond anymore.

Here my suggestion for the documentation: Please be more specific on which file to download from TeamWin.

Any ideas on how I could recover the tablet are much appreciated. This was a costly adventure. Hope the easy installer will soon support more devices.

I’ve managed to move from latest stock Samsung firmware (Android R) to /e/ (Android S)
At first, no problem with flashing vbmeta.tar with Odin. But right after having the OEM unlock i had to make a hack with the date (as i did not want to wait for 7 days ;))
Flashing the /e/ recovery (or lineageos one by the way) was not possible with Odin, neither with Heimdall : first Odin crashes if the name of the recovery tar file is to ‘complicated’, and I had to rename the .img before taring to avoid crashing. Second problem with this recovery flashing (with Odin - any version - or Heimdall) was a systematic failure . I did not find its cause…
So this procedure worked for my tab : 1) flash twrp recovery with Odin (this one worked), 2) go to recovery (twrp) and copy the /e/ recovery with MTP from the PC 3) flash it with twrp (install to recovery feature). Then go to /e/ recovery to adb sideload /e/ os.
All is working well so far. I just would like to get rid of the warning when booting the tab, but this one is minor issue.
Reading lots of article on this forum and xda one helped me a lot! Thanks to people who shared experiences and tools :wink: and of course thanks to /e/ team !!

I just got a galaxay Tab S5e (SM-T720, gts4lvwifi) and I wonder if there is a proper documentation on how to install /e/OS with a Linux laptop (I don’t have a Windows machine available).
I managed to install a Tab S6 Lite ( gta4xlwifi) afew month ago so I wonder how different the procedure is. Would the install guide for the S6 work with des S5e as well?

1 Like

Already having a Galaxy S9 with /e/os on it ages ago and even recently updated to dev ‘T’ using the Linux command line (Heimdall and adb), I assumed this would be the same (or a very similar) procedure for the Tab S5e… However, the documentation implies I need a Windows machine and Odin(!) - Being privacy conscious, I only have Linux PCs, so this is a plus one to ne20002’s request for some Linux procedures.

…scratching head at Linux only installs of /e/os on to Tab S5e raises 2 questions:

  1. There is a now an updated linux odin4 since Aug '23 - has anyone used?

  2. or could Heimdall 1.4.2 be used to flash VBmeta along the lines of:?
    heimdall flash --VBMETA_SYSTEM vbmeta.img
    (c.f. using heimdall on apple macs

Ok, I decided to try to use the Linux version for Odin.
I will edit and update this post to write what I did and what worked different from what is written in the installation howto.

I downloaded latest adb, the 1.16 t /e/OS files (zip and recovery) and Odin for Linux and placed all into a folder.

  1. :white_check_mark: I manged to complete pre install instructions until including point 5.

  2. :white_check_mark: I added the udev rule and blacklisted cdc_acm as decribed here. When plugging the tablet (still on Samsung firmware) it now shows up as mtp:// device and the content on the tablet is accessible in Linux Mint.

  3. In the installation howto it states to flash vbmeta.tar to AP partition but here is states to flash vbmeta to CP.
    :question:Which one is the correct one for flashing /e/OS?

1 Like

Technastics linux odin4 documentation is useful as it brought to our attention a potential linux tool that is not prior referenced within extant /e/os documentation. Its procedures however do raise new questions - in particular, an apparent contradiction:

odin4 -a recovery.tar -c vbmeta.tar

c.f. with /e/os pre-install procedure for s5e, point 10 - which implies installing vbmeta to AP (rather than CP suggested in techtastics’ procedures)…

These inconsistencies appear elsewhere on the web too and so hence the doubt - maybe it doesn’t matter(?)

Any clarification from the authors of the /e/os install procedures would be much appreciated :question:

Hi @Manoj
As you may see, we’re struggling on how to use the odin4 linux tool to flash the Galaxy Tab S5e. I don’t want to brick my device so I would appreciate if we can get an answer (maybe from a dev) on how to do this? Would this be possible?

Kind regards

Hi @piero
Thank you for the answer. So the official install howto stating to install vbmeta on AP is wrong, right? Other than that I should follow the steps as described?

Hi @piero,

You can see why we are confused…

A Lineage how-to suggests VBmeta destined for AP(:interrobang:) also here… and so the /e/OS documentation too.

But your brief prelude to a more scripted answer implies you agree with Technastics by putting VBmeta to CP…

Please could you explain this?


it was an advice from the s10 series official maintainer :
found here on TWRP website :

the link to xda is not present on TWRP webpage for the Tab S5e :

but you are right, about gts4lvwifi it is mentioned AP here, could be AP (don’t worry be…) :

1 Like

I continued by following the /e/OS installation howto skipped all steps relating to windows (6 - 9). Instead I prepared a terminal window with command

./odin4 -a vbmeta.tar

I booted into download mode as described and started Odin4.

pi@pcpi:~/Entwicklung/platform-tools$ ./odin4 -a vbmeta.tar
Check file : vbmeta.tar
Setup Connection
Receive PIT Info
success getpit
Upload Binaries
Close Connection

The system rebooted and popped into emergency screen where I followed the instructions to ‘Factory Data Reset’. After this the device booted, showed the red warning text about not running official Samsung software and I started setting up the device again freshly.

So this is until step 16.

I then reenabled developer option and checked that OEM Unlock is still enabled (is enabled and switch is disabled). So I assume the Pre-Install instructions have been worked through.
Also, Odin4 on Linux seems to work :slight_smile:


And it worked. :slight_smile:

I installed the recovery with Odin4. Right after downloading the recovery.img the device rebooted and you need to switch immediately to hold Power + VolumeUp to boot into recovery.

  1. Boot into download mode
  2. Select continue
  3. Start download of recovery with Odin4
pi@pcpi:~/Entwicklung/platform-tools$ ./odin4 -a recovery.tar
Check file : recovery.tar
Setup Connection
Receive PIT Info
success getpit
Upload Binaries
Close Connection

When rebooted in recovery, follow the /e/OS installation how-to.

pi@pcpi:~/Entwicklung/platform-tools$ ./adb sideload
* daemon not running; starting now at tcp:5037
* daemon started successfully
Total xfer: 1.00x                                                    

If you don’t get the switch to recovery, it must really immediately when the device reboots, the device boots into the stock Android again. Just retry with again starting to download the recovery.img until you get the right moment.

Thank you all very much.