Samsung - Galaxy Tab S6 Lite (LTE) - gta4xl - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

I followed the instrucitons with little problems, in fact really only the physical challenge of booting the tablet into download mode. My only suggestion is to explain how to power off from download mode (press and hold power + volume down).
Thanks for a well working process.

I just realized that this place is only meant to be for documentation suggestions - sorry. I would like to suggest that a couple of photos would help, e.g. one showing the upload bar (as I said, on my device it is at the bottom of the screen) and what it means that “When the status message in the top left of the device’s display reports that the process is complete”. I didn’t get such a message, it is just that the upload bar is full. However, maybe that is the problem?

After flashing Android 12 on the device, the installation went smoothly. Now I think I understand what is meant by “It is important that you know that downgrading Smartphones on OS versions greater than the /e/OS OS version you plan to install, can cause instability or at worst brick some devices. We recommend that you check your current OS version, before attempting the installation.” However, I didn’t understand it at the beginning.
My suggestion (if I got it right): “If the OS version on your device is greater than the one specified for the /e/OS version you plan to install on the Download site, the installation of /e/OS can cause instability or at worst brick some devices. We recommend checking your current OS version and considering a downgrade before proceeding with the installation of /e/OS.”
Moreover, on the Download site, the versions of Android are given with capital letters “R” and “S”. I had to search the internet for what that stands for (and since I didn’t do that on my first try, that was part of why I didn’t understand the paragraph above), since nowhere on the device the OS version is so specified. It would have helped me a lot if the number was also given on the Download site: Android 12 (S), or something like this.

I just got the tablet and wanted to put /e/ on it. However, OEM unlock is greyed out. I did the “adb reboot” part, but “fastboot devices” never showed the tablet.

I found hints that I should press “volume up” and “volume down” while rebooting and connecting, but volume up and down are the same key on the side and it did not have a notable effect during reboot.

I tried moving the date/time > 7 days in the past and future, but this did not change anything either.
suggested to disable additionally “Software-Updates”, but this menu is greyed out as well. suggested to enter a string in the dialer. However, nothing happens, i.e. the string does not disappear and if I press “dial” I the correct infomation, that the mobil network is not available.

Are there other know ways to ungrey “OEM unlock”?

Samsung devices previously displayed a condition “Prenormal” until Samsung Remote Monitoring had established that the phone was in normal use with a retail customer.

More modern devices do not reveal this. The install page includes the note

Enable OEM unlock in the Developer options under device Settings.
It appears sometime that the OEM unlock option is missing from Development options, especially on new devices. Please connect your device to the wifi and check of system updates. After a reboot, the option should appear.

Have the device in “normal use” for 7 - 14 days with SIM card and Wi-Fi in operation.

These more modern devices seem to have increased security on the unlocking of the bootloader and don’t seem to respond to fixes, which worked in the past you already tried. Another consideration is that you are using the device in the region of the world where Samsung intended marketing. So an Asian intended market device might not ever release in USA for instance.

Know your hardware - Samsung

Thanks for your quick reply.

We took the device into operation yesterday and it installed about 5-6 system updates, as per install notes we waited until no further update was shown. This process took several hours.

This device is not intended to carry a SIM card, is this a problem? Of course, we can “run” it for ~ two weeks. And I don’t know where the device orginally comes from, as we bought it refurbished.

I will read the referenced document in a moment, thanks for the pointer!


Please just be careful that you get the correct ROM for the device, you are asking on the LTE Documentation Suggestions page, hence short answer!

Different device

The device has a SIM slot, so I believe I’m correct here, just not a SIM (I intend to use it as WIFI only).

I see. So it us possible that your using no SIM card will be an issue only in this 7 - 14 days, we cannot tell with a refurbished device. Can you get a “taster / demo” SIM card?

If you would be very disappointed if this never works perhaps you should tell the seller what you plan to do and ensure you can return it if it does not meet your expectations. You could even try to ask him if it is a “grey import”.

Experience in this forum indicates perhaps USA customers most often experience Samsung problems.

“N” is for “Nougat”
“O” is for “Oreo”
“P” is for “Pie”
“Q” is for “Quince tart”
“R” is for “Red velvet cake”
“S” is for “Snow cone”
“T” is for “Tiramisu”

That are original version names of gogol releases.

Fastboot is not for Samsung devices

Are you sure to have a gta4xl / SM-P615 ?
What is the OS running on your PC ?

I’ll see about the SIM card. I’m in Europe, so hopefully I don’t see the problems American customers did.

The device is a SM-P615, several stickers on the back say so (and I double checked when buying the device). It also says so in the “About this tablet”. I’m running Debian GNU/Linux stable on my main computer.

Regarding fastboot:
The install instructions link to On this second page two ways to unlock the OEM are shown. The first one did not work, so I also tried (without success) the second one. From your reply I assume that the second one is not applicable for this device?

I am very disappointed :frowning: I bought a Galaxy S6 lite with the intention of installing /e/ on it, but have been unable to persuade my computer to recognise the USB interface. I can get it into developer mode, and can initiate Download mode, but heimdall and adb do not work.
dmesg says “unable to enumerate USB device” Sometimes it recognises the usb interface before entering Download mode, but never once Download mode works.

I have tried three different USB cables, on USB2 and USB3 interfaces, and also on another computer. I think I must have a defective USB interface.

Shame. It looks like I shall have to put up with all the Samsung and Google crud.

fastboot is not for Samsung…

This generation of Samsung seem quite difficult to get past the stage which I tried to explain here (but I don’t have first hand experience) Post #8

1 Like

Yay! I managed to get past the USB issue.
I found a combination of cable and usb port which worked long enough to install /e/.
Hopefully it will be a long time before I have to struggle with that again.

1 Like

Yep, SIM card is required. We used it a few days with a SIM card and now OEM unlock is possible. I’ll see later this year (no time atm) to finally switch over to /e/.

Thanks for your help.