Samsung - Galaxy Tab S6 Lite (Wi-Fi) - gta4xlwifi - Documentation Suggestions

Will wait for another user to confirm and have the changes made to the documentation.

I think it was the same with my Tab S6 lite flashing. However I wasn’t sure if I’m just to slow after reboot with Volume Up and Power

A guide for installation using ODIN would be very helpful.
Tried a day to install eOS on my Samsung Galaxy Tab S6 Lite (Wi-Fi) using Heimdall as in guide explained. Couldn’t get heimdall working on Win10 and on a virtual box ubuntu distribution. Pretty frustrating.
But tried an easier way like I already did for my Galaxy s4 using Odin to install the eRecovery after following steps:

  • download eRecovery and convert the .img file to .tar using this script (https://forum.xda-developers.com/t/script-tool-how-to-create-a-tar-md5-file-from-img-for-odin.2446269/) (pretty easy to handle!)

  • Boot into download mode:
    → hold Volume Down +Volume Up and connect the USB cable
    → long pressing of volume up to unlock the bootloader
    → boot in download mode again

  • Start Odin: untick “Auto Reboot” and select the converted .tar file in “AP”.
    → Press start and wait till Odin shows “Pass!”.

  • start eRecovery by pressing volume down and power (5-7 seconds) till screen turns black and move to volume up while pressing power. Then you should get into eRecovery.

Next steps I did after installation guide.
For adb sideload, make sure adb is working!
Took me just 5 minutes using Odin. Could be a variant for people who don’t get heimdall working!!

Generally the instructions are actually complete in respect to locking bootloader.

The instructions do not include lock because it should not be done ! A search of the forum will give some fuller answers.

Please do not attempt to lock the bootloader on this device when using /e/OS.

There is no “verified-boot” on “dev” builds, It is only available for some “stable” builds (FP3/FP4)

I can confirm what @confu wrote.

I wasted a lot of time getting into recovery mode after installing the recovery image. It definitely needs to have the USB cable connected to the PC.

The point 6 “Unplug the USB cable from your device.” should be removed.

1 Like

I do confirm this. Found out the hard way - before reading this suggestion :laughing:

The point has been removed from the guide.

@Manoj at our flash-party next month, I’ll have to flash one of these devices.
I see that https://doc.e.foundation/devices/gta4xlwifi/install still mentions Android 11 as a prerequisite before flashing. Is it still true, or should this statement be updated in the doc (to mention Android 12 as a prerequisite, instead of Android 11), as @Pierro said above (it seems to make sense)?

However, as R binaries are still available for download, maybe the text should be something like:

“Warning: Before following these instructions please ensure that the device is on Android 12 firmware to flash /e/ OS version S, or on Android 11 firmware to flash /e/ OS version R (it must be the same Android underlying version)”

It should display Android 12. The guide has been updated to display the correct value. Thanks for pointing this out.

1 Like

I am stuck at the point „Only official released binaries are allowed“ after I did the „heimdall flash —RECOVERY … —no-reboot“
which ends with
ERROR: Failed to receive session end confirmation!
Releasing device interface…

The img was uploaded (progress bar moving) but at the end above message is shown on tablet and the upload is ignored by the tablet.

What exactly did you do to overcome this?

the „date trick“ from last link seems to have solved the issue
strange, but I am now in /e/ recovery mode

(OEM was already unlocked and developer mode available, I did only the date related changes)

edit:
Meanwhile /e/ is installed

Additionally the hint from above was necessary to follow:

„6. Manually reboot into recovery, this may require pulling the device’s battery out and putting it back in, or if you have a non-removable battery, press the Volume Down + Power buttons for 8~10 seconds until the screen turns black & release the buttons immediately when it does, then boot to recovery:

  • Reboot and immediately hold Volume Up + Power while the device is connected to a PC via USB cable.“

The the page behind „Install heimdall“ could be updated with the information, that for Ubuntu heimdall is part of the repository and can be installed with „apt-get install heimdall heimdall-frontend“

1 Like

Another thing to watch when installing from LinuxMint is to make sure you are on Heimdall 1.4.2. I tried it first with Heimdall 1.4.0 since that is what most installers you can find are for. Heimdall would not communicate witj the device until I upgraded to 1.4.2. I think this would apply to most Ubuntu distros to need 1.4.2 for it to work properly from what I read elsewhere.

I just finished flashing. Once the recovery image was flashed, everything went very smoothly.
But before that I ran into a few issues that might be clarified further in the documentation.

  1. Make sure that you stay connected to wifi at all times. This might reduce the chance that a Samsung device sinks into ‘Prenormal KG/RMM state’, and this could potentially halt the installation process for 7 days. (Also, it took me some time before I realised that I actually was in prenormal state myself, so it is good to emphasise
    checking whether the OEM Unlock toggle is missing.)
  2. I didn’t get Heimdall working after many, many attempts. I agree with @Luke to suggest the alternative ODIN install for Windows users. This would make the process much smoother.
  3. Me, personally, I didn’t want to use ODIN this time, as I thought I had to first manually flash TRWP as well; (this is suggested in another forum thread ). But because I couldn’t find the right version for the S6 Lite, I didn’t want to go there initially, until I got really fed up with heimdall. So a side note that manually flashing TWRP is not needed here, would have made the installation easier.

So far my suggestions, hope they are useful.
The rest was really super smooth!

(And now i am going to play with my first-ever, privacy friendly tablet. :smiley:)

1 Like

I also could easily upgrade my tablet with the official instructions (adb sideload), from a r version to 1.14-s

It’s real relief to not have to re-install/re-configure/re-transfer everything…

@Luke Thanks for this fantastic tip which worked a charm and got me out of a download mode boot loop.

I think the install guide for this tablet should link to your post for a Windows/Odin installation rather than to the existing How To which is seriously out of date and does not work with this model. If you follow the Odin/TWRP route as suggested, you will end up in a boot loop like me.

The doc should be upgrade,there is an important missing step as describe here

The OEM unlock method isn’t right on the doc.
Thanks

In de instal guide it tells to upgrade the device, so I did. Now it’s on A13 and can’t install latest e/os version. I tried downgrading to A12, but without luck.
Probably a good idea to change the install guide to carefully or manual update to A12. Or is there any way to install the S version of e/os?

1 Like

There is anti-rollback feature, so downgrade might not be possible.
So either you wait until /e/OS-T for the device is officially released, or you use my unofficial build:

1 Like