Samsung S6 Lite: problem with installation


I purchased a new Galaxy Tab S6 Lite SM-P610 for use with /e/OS. But I’m stuck on the installation.

I followed the guide here (Install /e/ on a Samsung Galaxy Tab S6 Lite (Wi-Fi) - “gta4xlwifi”) and managed to unlock the tablet (developer options say: already unlocked).
I can boot into download mode and start sending recovery image downloaded from (/e/ image ROM download) version 1.1.
The tablet accepts download and heimdall on Linux PC says:

Heimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
PIT file download successful.

Uploading RECOVERY
RECOVERY upload successful

Ending session...
Releasing device interface...

The installation guide says:

A blue transfer bar will appear on the device showing the recovery being transferred.
Unplug the USB cable from your device.
Manually reboot into recovery:
    With the device powered off, hold Volume Up + Power.

I get the transfer bar and it seems to be filled up to the end. Screen is on and still says downloading. Option is to press power and volume down for seven seconds to cancel … no other options.
Removing the cable does nothing, screen is still there.
When using option (press power and volume down for seven seconds) device powers down.

After this: device does not power into recovery when using (Volume Up + Power). Says software is not Samsung official and boots into Samsung Android …

What am I doing wrong?

I hope you might find that question answered here: Know your hardware Samsung #Your first boot into TWRP

Boot Modes

Recovery :
With the device powered off - hold Volume Up + Power.
Download :
With the device powered off - hold Volume Down + Volume Up and connect the USB cable.

1 Like

Ok, not really a step forward.
The video is quite helpfull. I did it exactly as shown (or described in the guide).
But the immediate boot into recovery from bootloader by resetting with power/volume down and switching to power/volume up does not work for me.
It always complains in red text that the device is not running Samsung software and then boots into Samsung Android.

I suspect the problem is the already installed Stock Android 12 on the device (it came with that version already).

So I see two options:

  • wait until /e/OS S is released
  • downgrade the device to Android 11 before switching to /e/OS.

I haven’t really found a way to do a downgrade. :frowning:

/How to/ install /e/ R on a samsung galaxy s10e already running android 12

Thank you.
Actually I have a few devices with /e/OS or waiting for /e/OS.

  • a S9 bought from Murena. For testing, official /e/OS 1.2 Q. No problems so far except the speaker makes a sizzling noise.
  • flashed an old Sony Z5 compact with /e/OS 1.1 R. For testing so far, working flawless, but just a backup device.
  • a S10e with Android 12 awaiting to get flashed with /e/OS. This is and should get my main device.
  • a S6 Tab Lite with Android 12 awaiting to get flashed with /e/OS. This should get my home internet browsing device.

I’m still unsure if I shall do the steps and take the risk to downgrade the S10e and S6 Lite or if it is easier to wait for /e/OS S which seems to be in the pipeline for both devices.

I hoped the S6 Tab Lite would have Android 11 out of the box. But it came with Android 12. :frowning:

I bought this device because I liked the idea of having a tablet with eOS, but as the user ne20002 exposed, after the step of sending the recovery.img file version 1.8 with the help of heimdall I tried several times to reboot in the recovery menu, but without success, no matter how fast I pressed the keys VOL DO + POWER and then VOL UP + POWER, as it always continued with the “normal” start screen of samsung.

I think I repeated this procedure so many times that unfortunately it now somehow seems to have corrupted the “boot”, as it now stays in a loop.

Then I tried to install the other recovery images (1.5, 1.6, 1.7), but the result was the same.

I don’t know if it will help, but I can still enter the menu to use heimdall and install a new recovery.img file, and my intention would be to hopefully re-install some original version of samsung, but I have had no luck in my search on the internet. Does anyone know of a place where I can recover these files?

Or is there any other option I can consider?

I appreciate any help

There is a list of archives of Samsung stock ROMs here Know your hardware - Samsung.

I know of no Official Samsung source of Stock ROMs.

Edit. It is also worth considering how new your device actually is.

Flashing /e/OS to a brand new Samsung
The 7-day buffer period discussed in this section will impact users of a brand new phone. During the Prenormal period, you can NOT flash any non-Samsung binaries. It would be a good idea to use the phone with a SIM card and online with wifi during this period. Source Know your hardware - Samsung Of course in the case of a WiFi tablet SIM does not apply, but connection to Remote Monitoring is still a factor.

You need to ensure the device is on Android 12 (not Android 13) before attempting to install

Perhaps you could clarify … is the loop to Odin / Download mode only, or something else.

1 Like

Hello and welcome,

Are you sure you’ve got the right 2020 exynos model ?
SM-P610 is gta4xlwifi
SM-P615 is gta4xl

And not the unsupported 2022 qualcomm edition
SM-P613 is gta4xlvewifi
SM-P619 is gta4xlve

Thank you very much for your answers…

  1. the tablet I bought was not new, but used, so I guess the 7 days period was not necessary.

  2. the model I bought is, according to the information given by the seller: SM-P610NZAADBT

  3. the models on the Know your hardware - Samsung websites start with SMP610X… and not like mine which is SMP610N (German edition)… and I don’t understand this difference.

Again thank you very much for any help

1 Like

germany version is enlighted by DBT at the end

1 Like

I do not think SM-P610NZAADBT vs PDA P610XXS2FWB1 or CSC P610OXM2FWA6 points to any sort of conflict.

Among apparently genuine German sellers, I seem to see

Manufacturer no.:SM-P610NZAADBT

When I look on Sammoble in a “Germany” search for SM-P610, I find

… where DBT represents Germany … I can find these details

Security Patch Level 2023-02-01
OS Version Android 13

If you have the device IMEI, you might be able to double check wth

Edit, a bit of an oversight of mine to point to Android 13, when you need 12 ! :blush:

1 Like

Unfortunately I can no longer work with the tablet today, because I am not at home at the moment.

I hope to be able to continue as soon as possible.

Thank you very much for the immeasurable help.

1 Like

latest android 12 based Samsung Firmware seems to be :
Download Galaxy Tab S6 Lite SM-P610 (DBT) P610XXS2EVJ2 in Samfw - Samsung firmware download


Apparently you can’t install this firmware using Heimdall (on linux).

So I will probably have to use the ODIN-fw-installer on windows.

(Unfortunately I was the last weeks inactive, because I was sick).

For anyone else who is looking into this lately, the May 2023 stock Android 13 update (build date 2023-04-28) seems to have bumped the firmware “security patch level” to 3 on the Wi-Fi tablet (SM-P610, gta4xlwifi) and 5 on the LTE tablet (SM-P615, gta4xl). Once you have this version I believe it’s not possible to downgrade the firmware to Android 12 for /e/OS. :cry: [1]

(German SM-P610 as discussed above, I have Australian SM-P615. Expect most variants will be the same.)

[1] Although it’s quite possibily for a good reason, to prevent rollback enabling a firmware vulnerability.

In theory, installing the offered combination firmware should be abble to reset the anti-rool-back-bit. But for today latest is 4.

/e/ should release a T based build Untill the end of the summer, …

1 Like

Until they do, there are already lineageos4microg Android 13 / T builds available

If you install one of these, you should be able to flash the /e/OS T build when it arrives, without having to reflash the stock Samsung ROM


Thanks pete. Ironically, I installed lineageos4microg first, which is why I’d already upgraded to the latest Android 13 stock and bumped the SW REV version. :slight_smile: . Happy to wait for the Android T /e/ OS release.