Samsung S8 - Don't work pin-code/password

Good afternoon, I’m using a translator.

I can’t set the PIN/password of the lock screen. After confirming the PIN code, it returns to the lock method selection menu and displays “An error has occurred in the Settings application”.
After the firmware for the first time, everything worked.

I was forced to reset my phone. After that, it is impossible to assign a PIN/password. I did different resets, flashed from different TWRP, flashed the service firmware - without result. It works on all firmware except this one.

Try and

Any suggestions?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I looked a bit around who else ran into this

those had more debug or solutions on them, could be different to your issue though until you have a stacktrace

… so it would be interesting what kind of exception occurs while you interact with the lockscreen (or lockscreen settings), can you use adb logcat?

Clean flash

yep, you have the same stacktrace as the “Fail to enroll …” user laschrokken in the Lineage Gitlab - but the error messages leading up to the stracktrace read a bit different, but are read/write related for the security enclaves.

Both are trustzone (TZ) / trusted execution enviroment (TEE) related, on-chip security facilities of the ARM platform, keeping keys.

I TeeMcDaemon: open: Open storage file "/efs/TEE/" [hardware/samsung_slsi/exynos8895/mobicore/Daemon/src/FSD2.cpp:173]
E TeeMcDaemon: open: Permission denied opening storage file "/efs/TEE/" [hardware/samsung_slsi/exynos8895/mobicore/Daemon/src/FSD2.cpp:177]
E TeeSysClient: mcOpenTrustlet returned INVALID_OPERATION (rc 0x9) [hardware/samsung_slsi/exynos8895/mobicore/ClientLib/src/native_interface.cpp:604]
E TlcTeeGatekeeper: Open session failed: 9

the user from the Lineage Gitlab had

E Tzdaemon: !@[ts] Failed to move /mnt/vendor/efs/tee/srt/.00000000-0000-0000-0000-474154454b45-2147483648 to /mnt/vendor/efs/tee/srt/00000000-0000-0000-0000-4
74154454b45-2147483648 with error 13
W         : [5:          tzlog: 1800] SW> gatekeeper [ERR] (gk_store_fail_counter:52) [store]failed to create fail counter file res=f0100001

What would I do? reflash efs / tz / tee partitions from official stockrom images.

1 Like

Manipulations with EFS did not help. But quite by chance the question was solved.

  1. We flash the firmware, do a reset from the recovery.
  2. Turn off the phone. “Hold down the Volume -” and turn on the phone (to boot in “Safe mode”).
  3. Set up the phone as usual, set the PIN code and fingerprint.
  4. Turn on encryption and reboot normally.

The firmware has started.

so what do you think made the difference, again to “flash the firmware and reset from the recovery” or booting in safe mode?

Safe mode.
After experimenting with the firmware/boot, I came to the following:
Without the “Safe Mode”, the phone issues an error about corrupted data every download and asks to format the “date” section via recovery. And so on in a circle. This is provided if you flash EFS.
Without the EFS firmware, the phone is not encrypted and the pincode/password does not work, but it loads without an error.
In safe mode, it loads without formatting and, after enabling encryption, starts working normally.


@peter080 maybe the easy-installer does not flash the efs partition? something missing in the dreamlte scripts?

It reads to me as the OP didn’t use easy-installer and went with odin/heimdal and flashed partitions individually - so was able to fix this selectively. You could repost to the easy-installer category for this issue, if dreamlte is missing the efs.img in the supplied zip

I reread the OPs comments when explaning the reset + safemode-boot procedure. I should be wrong that this is about flashing the efs partition individually - it is not part of the shipped Zip file.

Maybe the safemode is copying over the missing file from a backup partition or corrects its access permissions in place and this is what fixes it.