Samsung S9+ Camera failure on installation. Help please

I’ve just installed e/os 1.9 on an S9+ and all went well.

However, when I try to use the camera the rear camera will not run- I get an error “an error ocurred while configuring the camera” (Simple Camera) or “failed to start camera preview” (e Camera). I treid other apps all with the same result of a black screen and an error message. If I try to see if I can take a picture despite the black screen, I then get “Serious Camera Error”

I tried Restore Settings and Reset Settings in the Camera app. No difference.

The front camera is working normally.

I tried a suggestion elsewhere on the forum to clear storage or clear the cache in Settings. Neither made any difference.

Please help!


Here is the debug log:

Camera v1.50.1
Code: 85
(c) 2013-2019 Mark Harman
Released under the GPL v3 or later (Camera also uses additional third party files, see online help for full licences and attributions.)
Android API version: 29
Device manufacturer: samsung
Device model: SM-G960F
Device code-name: samsungexynos9810
Device variant: starlte
Language: en
Standard max heap?: 256
Large max heap?: 512
Display size: 1440x2792
Display metrics: 1440x2792
Current camera ID: 0
No. of cameras: 3
Multi-camera?: true
Camera API: None
Camera orientation: 0
Photo mode: Standard
Min zoom factor: 1.0
Max zoom factor: 8.0
Preview resolutions: 2560x1440, 2224x1080, 2048x1152, 1920x1440, 1920x1080, 1440x1080, 1088x1088, 1280x720, 1056x704, 1024x768, 960x720, 960x540, 800x450, 720x720, 720x480, 640x480, 352x288, 320x240, 256x144, 176x144
Preview resolution: 1920x1440
Photo resolutions: 4032x3024, 3984x2988, 4032x2268, 3024x3024, 2976x2976, 3840x2160, 3264x2448, 4032x1960, 2880x2160, 3264x1836, 2160x2160, 2560x1440, 1920x1440, 2048x1152, 1920x1080, 1440x1080, 1088x1088, 1280x720, 1024x768, 1056x704, 960x720, 720x720, 800x450, 720x480, 640x480, 352x288, 320x240
Photo resolution: 4032x3024
Video resolutions: 3840x2160, 4032x1960, 2880x2160, 3264x1836, 2160x2160, 2560x1440, 1920x1440, 2224x1080, 2048x1152, 1920x1080, 1440x1080, 1088x1088, 1280x720, 1024x768, 1056x704, 960x720, 960x540, 720x720, 800x450, 720x480, 640x480, 352x288, 320x240, 256x144, 176x144
Video quality: 6
Video frame width: 0
Video frame height: 0
Video bit rate: 0
Video frame rate: 0
Video capture rate: 0.0
Video high speed: false
Video capture rate factor: 1.0
Auto-level?: Available
Auto-level enabled?: false
Face detection?: Available
RAW?: Available
HDR?: Available
Panorama?: Available
Gyro sensors?: Available
Expo?: Available
Expo compensation?: Available
Exposure compensation range: -20 to 20
Manual ISO?: Available
ISO range: 40 to 1250
Manual exposure?: Available
Exposure range: 100000 to 200000000
Manual WB?: Available
WB temperature: 1000 to 15000
Optical stabilization?: Available
Optical stabilization enabled?: false
Video stabilization?: Not available
Video stabilization enabled?: false
Tonemap curve?: Available
Tonemap max curve points: 128
Can disable shutter sound?: Available
Camera view angle: 66.56142 , 50.235897
Flash modes: flash_off, flash_auto, flash_on, flash_torch, flash_red_eye
Focus modes: focus_mode_auto, focus_mode_locked, focus_mode_infinity, focus_mode_manual2, focus_mode_continuous_picture, focus_mode_continuous_video
Color effects: none, mono, negative, sepia, posterize, aqua
Scene modes: None
White balances: auto, manual, incandescent, fluorescent, daylight, cloudy-daylight
Magnetic accuracy?: -1
Using SAF?: false
Save Location: OpenCamera
*Save Location SAF: *
Parameters: None

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Is it an idea to go back to stock android?

Do you know if there is any possibility that there was an Android version mismatch between your preexisting Samsung Android version and the /e/OS Android version ?

I cannot comment helpfully on your debug log, but a firmware mismatch (due to Android version mismatch) might typically prevent any camera app from using one or more of the physical cameras.

An Android version mismatch would, imo, be a sufficient reason for reverting to Samsung stock ROM.

Thanks for the reply.
The phone was on Android 10 before I installed e/os. I used TWERP and Odin to install. Is e/os 1.9 Android 10 compatible? I presumed it was!
Something interesting is that the Easy Installer always failed at the very end, hence why I used TWERP and Odin to install.

We are looking at a failed install … maybe I sound pedantic … the significant thing would be

Is e-1.9-q-20230310268292-stable-star2lte or e-1.9-q-20230312268823-dev-star2lte Android 10 compatible.

So yes, Android 10 | Q | q all good.

So one would ideally check that the device was fully up to date Android 10 … too late now :slight_smile:

… another unknown …

I feel is something of a judgement call in this case.

Maybe someone will recognise something in your debug log which would suggest an /e/OS issue, but seems less likely if the error were very much the same with every camera app you tried.

Is it worth double checking the Feedback for v1.9 thread to see if anyone else reported a similar S9+ camera issue ?

Thanks. I used stable 1.9 but I’ve no idea if it was q or not- I just took the very latest on the website. Maybe I should have been a bit more cautious!

I have TWERP on the phone- is there anything useful I can do with that?

You could simply do a factory reset with >80% charged battery – this would rule out the possibility of a first boot in some way incomplete.

(60% is considered enough; in the case of a phone “new to me” I would allow extra in case the battery is a little tired though lack of use.)

1 Like

OK I will trythis ! Thanks

OK SOLVED! :slight_smile:

So it was my bad- I was installing starlte and not star2lte TWRP version.
Interstingly it installed fine with the wrong version of both TWRP and of e/os…but the end result was that the front camera failed.
The moral: check the TWRP phone specific version and then the correct version of e/os will be asked for.