Samsung S9+ stuck on 'Keep read only' install step

Hi all,

I have tried installing /e/ on my Samsung S9+ several times now using the easy installer, but it always gets stuck on the step where I select ‘Keep read only’ on my phone in the install. My issue is that after I select it on my phone, nothing happens with the easy installer. It just sits there waiting for me to click it. There is no continue button. I have noticed in another topic someone suggested rebooting the phone to get past this, but that hasn’t helped unfortunately.

Looking forward to your help.

Log: hastebin

Hi @Admiralbenbow, welcome to the /e/ forum. Your log shows
Uploading RECOVERY -> RECOVERY upload successful
twice, then multiple


So … did TWRP install?

This is the Keep read Only screen on the device. Did you see it?

  1. If yes, did you follow the exact instructions of when to connect or disconnect the USB cable, try a different cable just in case, or think about doing a manual install following the last (easier !) section of this tutorial, picking up from 8) Install /e/ with TWRP [HOWTO] Install /e/ on a Samsung smartphone with Windows easily

  2. If no please read Know your hardware - Samsung #Easy Installer and also #Your first boot into TWRP then try again !

Hey, Thanks for your help. For some reason when I went through the process the 4th time it worked like a charm. Not sure what the problem was, maybe I just had to be ready to take over and go manual.