SD Card corrupted in phone and all files accessible on computer

Have FP3+ with the latest OS update.
When selecting Storage in the Set-up menu, it says that the SD card is corrupted and ask me to format it.
Have connect the SD card to my Linux computer (Ubuntu), and all the files are present. See attached for the card setting.
Have backed-up the SD card on the computer.
What should I do know? Format the card on the phone?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

give /usr/sbin/fsck.exfat a try? (sudo fsck.exfat /dev/sda1)

user@thinkpad-l13-bernie:~$ sudo fsck.exfat /dev/sda1
[sudo] password for user:
sudo: fsck.exfat: command not found

you want to install - (debian has it packaged under the same name)

I’m not a linux expert.
Here is what I have done.

sudo apt-get install autoconf libtool pkg-config

Extracted the release ( exfatprogs-1.2.0 version released) in snap and in downloads (don’t know which one is good).

And tried to install it as is :
user@thinkpad-l13-bernie:/$ sudo apt install downloads/exfatprogs-1.2.0.deb
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
E: Unable to locate package downloads

What did I do wrong?


if you run a debian(-based) distribution, it should already be packaged to just “apt install exfatprogs” it. Maybe not the latest as of writing (1.20) if not on sid.

Sorry again…
user@thinkpad-l13-bernie:/$ apt install exfatprogs
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

yep, apt is a sudo command apart from the query things

Finally it works. Thanks for your patience and support. :slight_smile:

And here are the results :
exfatprogs version : 1.1.3
ERROR: /Android/data/org.telegram.messenger/cache/-5956246936557194221_1109.temp: first cluster is wrong. Truncate (y/N)? n
/dev/sda1: checking stopped. directories 1164, files 5568
/dev/sda1: files corrupted 1, files fixed 0

When I go in the Android/data/org.telegram.messenger/cache/ , the folder is empty, even when I select 'Hidden files"

And curiously I have 2 Telegram folders on android. there are files in both. One is related to files I have watched and the other is related to files I have saved on the card. Should I keep both? Or move the files from “Telegram (1)” to “Telegram” and delete the first one?


(I don’t know how telegram manages its folders. But you’d be safe to delete the contents (not the folder itself) of most cache/ directories)

But more important - is the exFAT sdcard now mounted by Android without issue?

Your Android itself has some version of fsck.exfat (1.1.2 when I looked for a v1.5 build), so if you enable adb root, you can run the fsck on-device if you unmount the sdcard. I wonder why it’s not trying to go for a repair first before formatting, though it could be the case already, I haven’t read the code

All the Cache are empty (see attached)

The exFAT sdcard was mounted by android without any problem. It ran fine until I changed a parameter in the storage of Telegram data. Then the Telegram app changed place on my phone and the app behaved wiredly on the phone. Maybe I need to remove Telegram and reinstall it. But if I insert the card in the phone, it won’t probably access the data on the card. Should I erase the /media/user/android/Data/org.telegram.messenger files on the card before trying to remove Telegram app on the phone with the card inserted?

How may I enable adb root on the phone? I would try this first.

Also, regarding the SD card, I did a back-up of all files to my computer, in case I need to format it with the phone and copy everything back to it.


Also, I realised that that I’m still at V 1.4-20220920220045 e/OS.
Maybe I should install 1.5?
With the card installed…

And now, I can’t connect my FP3+ to my computer anymore via USB…
SD card inserted, still corrupted.
Message attached

In the same time, I am updating to V1.5 e/OS.

I might simply format the card on my phone and then, transfer all files from my computer back to the card.

What do you think?

(no need for adb root anymore, just for later readers a nod that fsck.exfat is available on their FP3)

The exFAT sdcard was mounted by android without any problem. It ran fine until I changed a parameter in the storage of Telegram data

on a timeline - this was before you created the thread, and before you ran fsck.exfat - so the fsck didn’t bring any change?

Reformatting by Android is the easy choice then. Not sure about telegram storage place though, but I guess the App is able to handle that it’s alternative storage target is gone

Edit: upgrading Android will not magically fix something. Android is unhappy with some “state” of the filesystem / its contents

Have formatted the sd card on the FP3+.
Still cannot connect my phone to my computer via USB.
Same Error message :
Unable to access FP3+
Impossible to open the peripheral MTP “003,040”
Maybe I need to fix this before restoring all my files on my sd card via my computer?
What does this mean?
Any idea?

mtp is a protocol you can use via usb to transfer files… not sure why it bailed. To do adb push/pull for file transfers, you wouldn’t need it though, it’s probably the way gnome is mounting it via gvfs Why don't I have MTP option in the USB menu - Android Enthusiasts Stack Exchange

I forgot to link, have you seen this description? After OTA sd card is not being read - #3 by GrimSkull

The card works fine and is recognised while on battery (I can mount and unmount it and no issues) The card is flagged as “corrupted” if I connect my device to the USB-C charger and urges me to reformat it, however once I reboot the phone and it is on battery again, it is fine…

I didn’t see that. Thanks.
I don’t think that it’s the problem for me.
Here is what I did :
1° I reformat the sd card on the phone
2° I restored all the files on the card with my computer (in files on ubuntu)
3° I put the card back into the phone
4° Selected the Android (external storage) for the pictures and with the camera
5° Selected the external memory for Telegram files
6° I moved the Telegram files from internal to external memory
It worked fine during 2/3 days, and then, today, it shows again corrupted card, while the phone was on battery.
I reformated the sd card and it’s fine now. But haven’t restored all the other files from my computer.
Still testing…

Here an update on the problems, not solved yet.
Have replaced the SD cards with a New Sandisk, last generation (same model as the previous one).
Then format it.
Switched the camera storage & Gallery to SD Card.
It works for a while, then card becomes corrupt again.
When I switch OFF & ON the phone, the SD card functions normally again until it becomes corrupt
Wondering what else I can try…

Switched the camera storage & Gallery to SD Card.

seems to whenever apps actually use the sdcard for /data/ storage it’s a problem for Android? probably the next time you take a photo or telegram is using it as storage destination.

I’d record the file+directory tree with selinux contexts at a time Android doesn’t determine it corrupted

adb shell ls -lRZ /sdcard/ | tee sdcard1.log

then after it hiccups do the same and compare (use meld <f1> <f2> or diff <f1> <f2>)

If you can reproduce it with one action you can also check adb logcat at that very moment what the OS is complaining about.