SecureGo gives notice about my phone being jailbreaked - but it isnt

My fellow community,

due to the changed TAN-method by the Triodos Bank Germany I must switch from the old mobile-TAN to push-TAN method, so I decided to download the SecureGo app (not VR-SecureGo! Triodos requests the app by Atruvia). Unfortunately, whenever I start the app it sends me to the VR-homepage and informs me that my phone is jailbreaked so I cannot use it. But: I tested this on the FP3 of a friends, also with eOS, and there the app dosnt show this message, it just works.
So I need to know: why isnt it working on my FP3, what am I doing wrong? Any ideas?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

If it works on one FP3 with /e/ and not on the other, I could think of differences like these

  • locked vs. unlocked bootloader
  • stable branch vs. dev branch (or even major Android version) of the /e/ OS
  • plain /e/ vs. “additional tinkering”
  • different versions of the SecureGo app
1 Like

Here is my setup which works on FP3 (in case more data points are helpful):

  • locked
  • stable branch Android 9 0.21-20220125159561
  • 22.01.0
1 Like

My bootloader was unlocked, so I tried to lock it via adb and now Im in big trouble: I cant access my custom ROM or TWRP, all my phone is doing is showing the fastboot mode. Via the command adb devices there is just an empty line, no device is shown. Before I worked via the command line and it all went smoothly until I executed fastboot flashing lock. Can you tell me what I can do?

Hey, I just tried to perform a bank transfer and now my SecureGo app is forwarding me to the following url:

which states the following:

Security notice
The security component of the VR-SecureGo app has detected a security-related issue with your mobile device and has therefore closed the app.

A jailbreak or root has been detected on your mobile device. This could compromise or override the security mechanisms of the operating system. For security reasons, you will not be able to use the VR-SecureGo app again until you have removed the jailbreak or root from your mobile end device.

If you have any questions, please contact your bank advisor.

I don’t know what to do, can anyone help me? It was working couple of days ago, I think it might be linked with me trying to access some logs via adb, but I even deactivated logging and the developer tools and I still can’t use it.

Anyone have an idea on how can I check that?
I am in big problems if I can’t use my bank account :frowning:

Nevermind, just went to Settings > System > Advanced > Developer options > Root access

it was set to “ADB only” I set back to “Disabled” now SecureGo is working again


This topic was automatically closed after 11 days. New replies are no longer allowed.