Security keys like Yubikey or Solokey not working

hello,

I bought 2 security keys. both Yubikey 5 NFC. one with USB-A and one with USB-C.
I would like to use them in the browser but it does not seem to work.
I have tried Brave and Firefox it always appears a general error message.
i tried tologin with github and with google. Username and password and then the security key as the second factor.
On my other smartphone with Google Android (Pixel 6 Pro) it works with both firefox and brave.

in the yubico authenticator app everything works fine. both via NFC and USB-C.
Is this an e/OS/ problem? has anyone had experience with security keys?

Hello,
I confirm this the same for me.I tried to log in to some services using security keys as the second factor, and I failed in all the browsers I tried. On some LineageOS Reddit thread I read that apparently the system level integration of security keys is a part of the Google Play services that are by definition removed from e/OS/. Until I find a workaround I’m going to use 2FA codes on my e/OS/ phone.