Shamu - Built for and installed on my phone

Currently testing a home build of shamu (Nexus 6) on my phone. So far, no errors found except I can’t install a TWRP so I keep getting a message that it’s out of date. Testing.

  • Phone working.
  • Wifi working.
  • Data working.
  • Email working.
  • Web is working
  • SMS (Signal) is working
  • Telegram is working
  • Contacts appears to be working.
  • Tasks appears to be working.


you build using docker ?

Yes. Using the instructions on the wiki.

i had followed the same but i face this error every time

I ran the build on Xubuntu 18.04 and didn’t get that error.

First, did you run the exact commands from ( ) except replacing “kiwi” with “shamu”? I see “herolte” as the device on your screenshot so I’m figuring this might be part of the problem. If you are building for “herolte”, I’m not going to be much help since I built for shamu.

Second, did you follow the Docker install instructions exactly?

Third, did you run all commands as “sudo”?

yes firstly i tried for SHAMU ,Its give error then i try again for Herolte .it gives same error

yes docker was installed correctly and yes i run commands and followed complete guide.

The error suggests the sync of the branch repository is not completing.

/e/src/EELO_0_1/vendor/cm is downloaded during the build process.

I would delete the entire /e tree from root, turn off any firewalls and try it again.

@saqlain were you able to build /e/ for your device?

no sir in this weekend i will try.

:smile: Good luck and do let us know what happened…

sure i will update about the progress