Signal GPS faux avec la dernière mise à jour sur Redmi note 9s

Bonjour,
j’ai installé la dernière mise à jour sur un Redmi note 9S.
(e-1.0 r 2022 05 27 qui a remplacé la e-0.23 r 2022 04 05)

Le GPS est inutilisable car complètement dans les choux.
Je suis en France et il me localise vers les Philippines à 11000 kms !
Je précise qu’il marchait bien avant la mise à jour et que l’erreur est sur toutes les applis utilisant le GPS (Magic Earth, Orux maps, GPS Status qui indique la réception des différents satellites)
Problème connu ? Est il possible de rectifier ou il vaut mieux revenir à une ancienne version ?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Bonjour.

Problème identifié lié au “brouillage” volontairement créé par AdvancedPrivacy. La solution donnée :

Bon courage.

1 Like

Le fait d’être situé à Manille est le fait du advanced privacy, sorte de VPN nouveauté de la V1, tu le trouveras dans les règlages ou sur ton écran d’acceuil en balayant vers la droite, avec les widgets.
Théoriquement, si tu le désactive tu seras de nouveau positionné correctement…théoriquement seulement pour beaucoup, perso je ne suis plus à manille mais nulle part, magic earth ne marche plus, GPS down.
J’ai posé la question sur le forum anglophone, l’info y tourne beaucoup et serait remonté, en attendant une MAJ.
Pour le fait de vider le cache expliqué au dessus, ça ne fonctionne visiblement pas, j’ai essayé, je n’ai pas l’option pour formater le cache

Je quote la réponse (mp) de @Bertrand_M :

Merci, je vais essayer cela,
C’est la seconde fois que je viens sur ce forum et je suis surpris, je ne vois pas de possibilité de répondre au fil de discussion que j’ai créé alors que je peux le faire sur la discussion dont vous m’avez envoyé le lien.


Pour ma part, j’ai conservé ma configuration avec,TrakerControl et Shelter et j’ai désactivé AdvancedPrivacy avec adb.

J’ai réussi :slight_smile:

  • accéder à Advanced Privacy (coulisser à droite depuis l’écran d’accueil),
  • aller dans réglage (roue dentée),
  • aller sur “Gérer ma position”,
  • choisir “Utiliser ma localisation réelle”.
1 Like

aucun effet chez moi avec cette manip :frowning:

Effectivement, j’ai eu le même problème (localisation aux Philippines) sur waze, osmand et autres GPS. Problème résolu avec Advanced Privacy, dans les paramètres de réglages. La bonne chose est que j’ai dû me débrouiller sans GPS pour trouver mon chemin. Tout est bien qui fini bien!