SM-J327U fails to flash system.img

Unfortunately, finding out why isn’t very simple… I thought it had something to do with the odd chunking of the sparse image file or the fact that it used ext2 instead of ext4. Is there something I’m missing here that could provide a clue?
It always fails a certain amount into the process.

You may need to flash boot.img first

Edit :
you are talking about a U variant that are usually not supported as one cannot unlock the bootloader ?

For what codename did you build ?

I… did…
I put boot.img, recovery.img, system.img, and userdata.img into a tar file and flashed with odin. It fails.

What do you mean by “U variants aren’t supported”? U means unlocked.

I built for the codename of the device, “j3popelteue”
I had to create my own device tree for it.

Generally, U means carrier unlocked, but not bootloader unlockable

Have you tried to install them using TWRP ?

What do you mean? In Developer Options there is a switch for “OEM unlock”

I tried installing system.img that way, and it succeeded. But it warns me there is no OS. Then boot loops.

For a split second, it says something about “KERNEL NOT SEANDROID ENFORCING”

Fake notification

in TWRP, have you formated /data, then reboot to recovery, wipe /system, and tried to flash your 4 .img using a queue ?
And finally wipe cache and davilk before rebooting to system ?

What’s a queue? I’ve never seen that option in TWRP. (also the userdata image that is built is basically empty)

All default apps are under system priv-apps

Isn’t it the same “add more files” ?

I went through that process, and it still doesn’t work. I wonder if I’m still missing a few device-specific files…
Heimdall has the same issue.

The mka build method I’m using doesn’t make those zips.

same issue… is it important that I’m building a version with Pie but this device usually runs Nougat?
I’ve tried building for Nougat and Oreo, but something is very different in the build system and nothing works at all.
My device tree doesn’t even get detected by the build system when building Nougat or Oreo.

Have you tried with selected minimal nougat (minimal list of default system priv-apps to avoid “/system size out of space error”) ? Minimal Pie should also possible

Does your environment has already built sussessfully /e/ for a supported device first ?

Twrp version ? or, Build error ?

You know that ?