SMS not sent for a particular number

Samsung S4 mini GT-I9195
Version system : 0.7-2019081520309 (latest)

Hi everybody,

I experiment a very special bug with SMS. Sending SMS to a particular number fails. And it works with all (about 10) other numbers I have made tests. No problem except with a particular number which has a normal form +336 XX XX XX XX.
The failure occurs when I use Message or KQSMS. No difference.
The answer of the soft is : “Message not sent”. I made about 30 tries with different forms of hone number (+336 XX XX XX XX, 6 XX XX XX XX, 06 XX XX XX XX, 06XXXXXXXX) …

Of course, I have checked that the receiving phone does not blacklist my number. The proof is that, when I use the same SIM card in another phone running a classical Googled Android, the SMS are sent to this particular number. No error.

Very strange, is’nt it ?

I suppose the only way to find the bug is to read the logs of the softs Message and/or KQSMS.
Do you know if current releases of these softs create log files in the system ?
If yes, where can I find them ?
If not, can I find development releases which create log files ?

Thanks for your help.

Hi @tunedomi that is a interesting bit of debugging you have done. Pl can you raise a issue here. You can attach a log generated after you try sending the message.

have you tried to call that number with e ? Will that work ?

I’m not sure if it is the same, but I can’t call different numbers when I have enable ‘Enhanced 4G LTE Mode’ under ‘Networks’ ‘Mobile Networks’ IF I disable it I can call every other phone number. If it’s enabled some phone numbers won’t connect.
So have a look and try without ‘Enhanced 4G LTE Mode’,

I had the same problem some days ago, after mistyping a number while attempting to send an SMS message. Tried to add a contact with the right number, nope :thinking:
I had to delete the whole “bad” conversation in Message to be able to call/SMS the number.
So I suggest to delete both Phone and Message history involving the number, and try again.

Hi @harvey186 , thanks for the idea. I tried it, but still not successful

It seems I will have to debug this by myself .


Hi @smu44, thanks for the idea, but I have already made this operation, and still not working.


good luck …