[SOLVED] After a battery shutdow, its looks like the phone is locked

Hi,
I installed E os on redmi 4x. It was going well since months but after a battery shutdown it looks like the phone is locked again.
Can’t access to E os, the MI logo appears and disapear. Can’t access to the bootloader.
I only acess to fastboot which means I can’t do the usual “Mi unlock”…

What could I do to unlock it again or format everything and reinstall ?

Bonjour la communauté,
j’ai installé EOS sur mon redmi 4x depuis presque un an mais après une extinction de batterie il semblerait que le téléphone soit vérouillé à nouveau alors que je l’avais dévérouillé pour l’installer.
A l’allumage, le logo MI apparait puis le téléphone s’éteind. Le bootloader (twrp) est inaccessible. Il ne reste que fastboot ce qui veut aussi dire que je ne peux pas à nouveau le dévérouiller par le logiciel “Mi Unlock” comme fait la première fois (puisque je ne peux plus régler les paramètres).

Comment le dévérouiller à nouveau ou formater et reinstaller totalement le EOS?

Hi,
It’s weird the phone get locked again :frowning:

Did you try to let it charge for one day or more, then power it on with our without charging cable attached ?
Did you try the “magic” key combo to boot into TWRP ? (3 keys pressed from power off, as described here : https://doc.e.foundation/devices/santoni/install).

I own the same device for testing, I’ll let it drain completely to check it I can reproduce your problem.

If fastboot is working, you can flash the stock ROM, but please be aware that you will lose everything !
Here is how : https://xiaomiflashtool.com/tutorial/use-xiaomi-flash-tool.

Actually it’s happen to @georgie_abitbol : Redmi 4X : blackscreen after logo

Last time it’s happen to me, I just Re Unlock the phone via (Mi Unlock) and everything gets back to normal. Now, its refused to Unlock it.

Yes I try all of that (charging, turn it on with or without cables, and all the keys, no bootloader avalaible anymore).

I know that the idea that the phone locked by itself looks weird, but last time, it looks to be that x)

I just hope if I re install everything that it will not repeat. Is there a way to unlock forever ?

I’m gonna try to flash the stock ROM so !

Same problem with mi flash than fastboot : Partition flashin is not allowed, because the phone is locked I think ?

Unfortunately, as I could read the only solution would be to open the device to enter EDL mode :


Sorry, I won’t do that, after some readings :wink:

Thx man, you helped a lot ! I never thought I will manage that weird autolock with… a paperclip. It work well as this comment said in the second topic you posted :

Dec 12, 2017 at 6:56 AM

So, I Googled the Test Point method and it worked like a charm! :laugh: Thanks for the info!! :good:

Basically you open the phone’s back, you unscrew a small metal plate and then you have access to 2 tiny dots, the “test points”, which apparently are built exactly for such purposes.

Instructions:
You unplug the battery (and the display I think although once it worked with the display plugged so don’t take my word for it), temporarily connect the test points with a pair of tweezers or a paperclip ?, while the test points are connected you plug the phone to the PC and it miraculously shows up in device manager under “ports” as “Qualcomm 9008”! (Qualcomm drivers need to be installed. If it shows up as “diagnostics…” anything, you did something wrong).
The device is flashable in that state, you use XiaoMiFlash to flash a stock ROM (it’s a folder that contains a folder named “images”. The flash tool doesn’t have you selecting specific files to flash, you need to select the whole images folder).

Pictures attached.
Left: the screws you gotta unscrew
Right: the test points and what you need to unplug

PS on opening the back: insert a flat narrow tool (best to have a smartphone repair kit) where the back plate connects with the front part of the phone (NOT where the glass meets the rest of the device). At first it won’t go in but be persistent and patient, eventually it it. Wobble it back and forth and go slowly around the whole device the same way, paying attention not to wound the parts under the side buttons. Once you do that, it’ll be possible to remove the back with your hands. Don’t yank it because you need to carefully unplug the tape connecting the fingerprint sensor to the motherboard first

image

SOLVED :smiley: :grinning_face_with_smiling_eyes:

I’m very happy you managed to get your santoni back to life ! :champagne:
We could sub-title this thread with “How to revive a phone with … a paperclip” :laughing:

BTW, could you please edit your first post and change title to “[SOLVED] After …” ? Thanks.
Or ask @Manoj if you can’t.