[SOLVED] /e/ installation fails on Oneplus 5t

build-issues
oneplus

#1

Hi,
Just got a OnePlus 5t and wanted to install /e/ on it. Following install instructions it works fine up to the point of the installation of /e/
I started talking about it on this thread but thought it desevers a separate discussion

Quick rundown of what I tried:
Installing /e/ via adb sideload > transfer “finishes” around 50% device shows installation failed message
Installing /e/ via internal storage > installation fails
Using different version of twrp > same result
Checking md5 hash of the /e/ install file > appears correct
Installing different version of /e/ > installation failed
Installing onePlus 5t firmware update 5.1.7 provided from the wiki page > installation failed

Pc is running windows 10, All tests were performed on 19.01.2019

Any idea what the issue could be?
Thanks,
Carlos


#2

Just guessing: Try the most recent TWRP version from the “cheeseburgerdumplings” project, form which you took the firmware.
Edit: or maybe the pie version of it :https://sourceforge.net/projects/cheeseburgerdumplings/files/16.0/dumpling/recovery/


#3

Hi Moose,

Thanks for your suggestions! I just tried both versions of twrp that you suggested, but still get the exact same behaviour :confused:
Really gots no clue what could go on


#4

@Carlos, I was thinking about your problem and I gotta question if you upgraded your ROM anytime or you got the stock one ?


#5

Personally I didnt do any rom upgrades, but the phone is 2nd hand. It runs more or less the latest oxygenOS, i.e. android 9. I think the oneplus 5t was originally released with android 7, you think that might be the main issue? I was wondering if I should attempt to roll it back to oero


#6

@Carlos the /e/ ROM was tested with the oreo build for Oneplus 5T so if you rollback to stock Oreo for your device and then follow the exact steps as given on the wiki the ROM should work.


#7

will try later on today, thanks!


#8

Hi @Manoj
Thanks for your advice, I rolled my onePlus back down to 5.1.7 aka oreo (Android 8.1.0) and then tried the whole thing again
I am still getting the same result though, Installation failed. When I try install the firmware referenced in the install wiki, I get the message: “This is a downgrade operation Need to erase user data, continue?” when I press “Yes” I just get the old “Installation failed” message.
Adb sideload method still fails at 47%
Any other ideas?


#9

@Carlos the adb sideload part can you try it through TWRP. There is an adb sideload option under TWRP under Advanced. Once there you can run adb sideload command from PC.


#10

Other very long shot @Carlos : TRY TO FLASH YOUR PHONE’S STOCK ROM. Then install /e/ as new one.

Remember that you need to install your stock ROM, TWRP, /e/ and SuperSU (If you like to have your phone rooted).


#11

@Manoj So far I’ve always tried adb sideload through TWRP i.e. the exact way you described it, I didn’t even realise you could do it through a different way

I think I may have found the issue :see_no_evil:
Just googled oneplus5T stock android recovery … i don’t think the way I flashed twrp worked, i.e. the whole time it was just using the standard recovery and me never having done this thought I was in twrp and it was all hunky dory, will post another update later on tonight when I get the chance to try it out


#12

:slight_smile: yesterday @rhunault and I were testing out an issue on our MiA1 tissot and tried to sideload through the PC and ran into weird errors …

adb sideload ota.zip
adb: sideload connection failed: closed
adb: trying pre-KitKat sideload method…
adb: pre-KitKat sideload connection failed: closed

when we went the TWRP route as described above it worked for us. Just let us know how it goes with you.


#13

Eureka! sure enough once I managed to launch into TWRP everything worked! So glad!
Thanks a lot guys! I really appreciate your help!


#14

Good to hear that your issue is resolved. Please can you elaborate as to what you did differently now…it might be useful for other users of the same phone.


#15

:clap::clap::clap::ok_hand:


#16

@Manoj
Sure! I watched a video of a guy flashing twrp and he had two extra steps might be either one of those, but im guessing its probably the later.

  1. copied the twrp image into the adb platform tools folder
  2. following the instructions i hadnt realised you can boot into recovery from within fastboot, and the adb reboot recovery command didnt work within fastboot. So previously i had rebooted the phone into the system after flashing twrp, from there i booted into recovery using the adb command.
    In my successful attempt i booted straight into recovery from fastboot by selecting the option with the vol down/up buttons (i had not seen the option listed, but could select it)

Also in my successful attempt i executed the flash command in powershell, but again i dont think that was it i was still using cmd for the other commands

After installation was complete twrp asks if you want the app installed, saying yes also messes with the install apparently. I had misclicked (because i got too excited) and after that it kept just booting into recovery. I redid the wipes/install checked the “reboot after installation complete” checkbox and disagreed to the twrp app install and it worked perfectly then :ok_hand:

Ha, such a noob mistake to not realise i wasn’t actually in twrp before :sweat_smile: