[SOLVED] Error 7 trying to install /e/ on galaxy S8

I’ve tried with the latest rom : e-0.9-p-2020061058046-dev-dreamlte
even whith an older : e-0.9-p-2020051454091-dev-dreamlte
still got this error.
I’ve tried to erase the assert infos in the updater-script, has said somewhere, but it says my Zip is not conform…
S8 i’m trying to install is a SM-G950F
What am i doing wrong ?
Thanks a lot for your help !

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

TWRP will show more than only error 7. Pls post the complete text

Is bootloader unlocked ?

Here’s the all text : Updater process ended with ERROR 7
Error installing zip file /external_sd/e…zip
Forget to say i’m trying to install that way (with TWRP installing), don’t know why adb doesn’t want to work.
That’s all.
Thanks for your help

the way is fine. But …have you done:

  1. FORMAT data (not only wipe)
  2. reboot to recovery
  3. wipe system, davlik, cache
  4. flash eOS with from external_SD

Yes, i’ve just try again as you said.
Still the same error.
It looks like my phone is saying it’s not a S8. No ?
Don’t really know what is the updater process.
I did it last week with a S9+ and everything worked fine :frowning:

As far as I now, there are different versions of S8.
Samsung s8 dreamlte
Samsung S8+ dream2lte

Are you using there right version ?
Has your S( an Exynos chip ?
Chipset: Exynos 8895 Octa
G950 F (Europe, Global Single-SIM);
G950 FD (Global Dual-SIM);

Chipset Qualcomm MSM8998 Snapdragon 83 5
G950 U (USA Unlocked);
G950 A (AT&T);
G950 P (Sprint);
G950 T (T-Mobile);
G950 V (Verizon);
G950 R4 (US Cellular);
G950 W (Canada);
G950 S /G950 K/ G950 L (South Korea);
G9500 (China)

1 Like

yes, i confirm, it’s an S8 G950 F.
I had no problem installing the twrp-3.3.1-1-dreamlte.img
It sounds like everything should be ok !

Ok, sounds good. I think you should use an older twrp. When I remember right the error could come from a bug in twrp. Try a 3.2 version

Thanks a lot for your help…
Exactly the same problem with TWRP 3.2 :frowning:
I really don’t know what to try. May be by modifying this updater-script file ?
But when i do TWRP my zip is not ok…

You can try, but it could be that you will get ‘forced closed’ or your SIM will.not recognised and no wifi.

So be prepared to have a working backup or working rom version on site

The problem is i don’t know what to do !
I don’t feel confortable doing this.
I’m sure i’m doing steps as you said.
I’ve tried 2 differents roms
Change TWRP from 3.3 to 3.2
and still the same error.

Which rom is running on your device? Original Samsung? If not, than first install latest stock rom. And than try again with eOS.
Sorry, that should have been my first question :frowning:

Yes, it was an official ROM. But i was thinking about re-installing the latest one and start again form the beginning.
I’ll let you know.
Thanks very much for you helps and so quick answers.

Hope you will.get it running

Indeed this error can come from an issue in TWRP, but the 3.3.1 is a working one :confused:

If you are abslutely sure it’s the rom for your device, you will have to modify the zip file to bypass the verification of the compatibility between your device and the rom.

1 Like

Done :slight_smile:
I have finally apply this solution : [SOLVED] Error 7 when flashing /e/ ROM on Samsung Galaxy J5 2015
I have read somewhere, that my phone name could have erased (don’t remember how). So i finally decide to erase the the “assert” section from the “updater-script” file and… everything work fine !
My S8 is now running under /e/.
Thanks a lot for your support and your help.
Sorry i don’t know how to transform the subjet as [SOLVED]

Good to hear. Enjoy eOS. I have edit the headline to solved :smiley: