[SOLVED] Google Cloud Messaging not recognized by Apps

Hello everyone!

I purchased a Samsung Galaxy S7 from e.foundation and am pretty happy about it so far.

But unfortunately, I can’t get Google Cloud Messaging to work.

This post didn’t help (I’ve got no ad blocker app - unless there’s one hidden in /e/ which I haven’t recognized), and neither did other searches on the internet.

So, what have I tried?

  • I managed to register my device for GCM in microG. The trick with *#*#2432546#*#* didn’t work, so I registered with a Google Account which I afterwards removed again from the device. Now it says “connected” in the microG settings.
  • I deleted all the data of an app (I tried this with several ones: Telegram, Signal, Threema), uninstalled it, checked nothing was left in the data folder, de-activated GCM, activated it again, waited until it said it was connected, and installed the app again - with no success.
  • I also tried rebooting the device after more or less each step, just to be sure.

Nothing helped; the list of registered Apps for GCM is still empty, and GCM obviously not working.

Any ideas about what else I could try?

(Btw. I’m having two entries named microG in the settings menu of the phone, one each under Device and System which lead to the same place - microG doesn’t appear to be installed twice. But still it makes me feel a bit insecure about it.)

I guess you have already done that but just to be sure : you need to open and setup the app (so for instance open and enter in your Signal account) in order to register an app with MicroG.

Yes it’s normal, and an update will soon come to remove the second “MicroG” useless entry.
(You have a phone with the “stable” branch because it’s a phone from e Foundation so you get updates later than those with a “dev” branch)

Please try this : [HOWTO] Installing Banking Apps

1 Like

Good to know, thanks!

Ah, yes, I did, but with no luck.

If in MicroG > “Google device registration” is enabled and in MicroG > Google Cloud Messaging you have “Connected since 2 minutes” (for instance), then I really don’t know why it doesn’t work.

Thanks for the link!

Well, the thing is that in the microG settings, it says the service is connected:

But for some reason, apps can’t register with it (screenshot from the Push Notification Tester app):

I’m a bit confused about that.

If nothing works, try to reset data & cache of MicroG. It will reset everything but that’s what I would do.

1 Like

Ok, I’ll try and report back if it worked.

Success! Thank you very much.

1 Like

With new technologies the solution is often : reboot/reset :yum:

Could you give a bit more detail on this? Having the same problem, and after adding and deleting a Google account GCM says it’s connected, but not sure how to do what you’re suggesting.

What I was talking about is to go in Settings > Apps > See all apps > MicroG Service Core > Clear data.

But it will reset MicroG, and you might need to reinstall the apps listed under Settings > MicroG > Google Cloud Messaging to get notifications properly for those apps.