[SOLVED]- Help please. Stuck at a specific step in the installation description, just before installing the new OS

RESOLVED: use the exact version of platform tools - see answer below

I got a new Gigaset GS290 with Android 10. All steps in the documentation for installing /e/ went as expected until the start of the final section “Install /e/”:

I just did “fastboot flashing unlock”, confirmed on the phone with volume up, got confirmation of success on terminal command line.

Next I wanted to “adb reboot bootloader” as described in the doc,
BUT now adb says that there are no devices.

On the phone screen I see in tiny font in about the middle of the screen the Select Boot mode choices and in the last line it says “=> FASTBOOT mode …” but nothing else happens from here.
All buttons seem to be dead. As a final option, I tried to reconnect USB cable, but neither effect.

I have no clue how to revive the device from here and make it visible again to adb?


“fastboot reboot” helped me boot the device from there. I’ll see where I can continue.
Suggestions still welcome, not sure what I did wrong, according to the instructions.

Second try - moved through steps again. Now here:

$fastboot flashing unlock
(bootloader) Start unlock flow
OKAY [ 26.417s]
Finished. Total time: 26.417s

$ fastboot flash --disable-verity --disable-verification boot boot.img
terminating with uncaught exception of type std::out_of_range: basic_string

Abgebrochen (Speicherabzug geschrieben)
translated: canceled (wrote memory dump)

So this time I went right to the next step which fails, but the file boot.img IS in the current directory.

Any idea?
BTW fastboot version 31.0.2-7242960 - i.e. newer than in your documentation.
A problem? I downloaded as described. I am on ubuntu

Thanks, Marcel

Hi @marcel.f, Another user experienced a similar problem.Turned out he needed to use specific version of platform-tools version r30.0.5-linux. USB Cable played a part as well.

Here is a link to that discussion where there is also a link to platform-tools r30.0.5 at post#9

Good luck!


Success. Using platform-tools r30.0.5 worked.
Thank you very much for your helpful pointer!

1 Like

I wonder:

  • Should I now relock the bootloader?
  • What’s the difference to leaving it open as is?
  • Is there a howto for this step, somwhere?

There is a report of someone bricking a GS290 by attempting to relock the bootloader, so I would avoid it! If you do not get a better answer you might start a specific thread as this one is marked solved! :slight_smile:

Thanks. As it works just fine, I am not up to further experiments, when I read this :slight_smile:

1 Like