[SOLVED] Mattermost cannot get notifications

Hi!

I use Mattermost v1.33.1 on /e/ v0.9-o-2020051554299-stable-star2lte on a Samsung Galaxy S9+ SM-G965F and cannot get push notifications.

A friend with Mattermost on GAndroid and connected to the same instance gets notifications, so:
i) I think the app Mattermost may work correctly and
ii) I am almost sure the server sends push notifications.

What I tried to fix the problem:

  • In the app, Settings -> Notifications -> Mobile -> Send for any activity, when I am online/away/offline. The test notification works.
  • In the system settings -> app & notifications -> Mattermost -> Notifications -> all on with priority set to maximal.
  • In the system settings -> battery -> Mattermost -> Battery optimization: disabled.
  • In the system settings -> confidentiality -> trust -> Mattermost -> all enabled.

Without effect.

Have you got the same bug? Did you manage to solve it?

Hi,

does this app use Google to send notifications ? If yes, check in Settings > MicroG > Google Cloud Messaging if the app is registered.

I don’t know, but does MicroG connect my phone to Google servers? Apparently the phone should be registered to Google servers to do this…

In Settings > MicroG > Device registration, you can see if the device is registered or not. And yes indeed it needs to be registered to have notifications.

It seems yes, that would explain… https://developers.mattermost.com/contribute/mobile/push-notifications/

So I prefer not having instant notifications than being connected to Google servers. Thanks for the explanations!

1 Like