[SOLVED] OnePlus 5T, /e/, LineageOS, OxygenOS, TWRP


a few weeks ago, I bought a reconditionned OnePlus 5T and immediatly installed /e/ on it. Now, to test some features, I would like to install back OxygenOS, and then LineageOS.
My problem is that I can’t manage it neither for OOS nor LOS.

As I couldn’t access to recovery (TWRP) anylonger (don’t know why, maybe something to do with the fact I flashed the 5.1.7 firmware a few days ago), I flashed the Blue Spark one as proposed in this topic. And it worked, I can access recovery through this one.
But when I try to sideload either LOS 16 (microG version) or OOS (dl from the OP website), I get an “error 7” fail. Then I try to update the firmware (as explained in the /e/ install wiki for the OP5T), but then, I’m back with the black screen when trying to access to recovery. Then back to flashing the blue spark TWRP. and reinstalling /e/ with simply work (but not the other ones)…
So that, for the time being, I’m stuck with /e/OS, which might be fine for the /e/ project, but not so cool for me.

Any idea anybody ?

Aim to get back to stock ROM. I would try booting into TWRP and format the phone’s memory. Then install OOS.

Thanks for your answer. What do you mean by

Wipe/Format data ? If so, I already did this, with no success ? Wiping every partition ? Internal storage ?

Sorry my question might seem stupid.

As I said here, I finally succeeded in going back to OOS. An old version but maybe through several update, I will have the last one and can compare what I wanted.

Thank you