[SOLVED] Still having problems with installing /e on my leeco le 2

Hi folks,
I’m still struggeling to get the ROM on my phone (LeEco Le 2 X527) :thinking:

The last error message is:

fastboot: error: cannot load ‘twrp-3.3.1-0-s2.img’: No such file or directory

I downloaded the TWRP file both to the phone and to my computer, where’s the mistake I made?

Any help appreciated…


Hallo Fachleute,

ich kämpfe immer noch mit der Installation der /e-ROM auf meinem Phone (LeEco Le 2 X527) :thinking:

Die neueste Fehlermeldung ist:

fastboot: error: cannot load ‘twrp-3.3.1-0-s2.img’: No such file or directory

Ich habe die TWRP Datei sowohl auf das Telefon als auch auf meinen Rechner geladen, welchen Fehler mache ich?

Bin dankbar für jeden Hinweis…


Servus @bixxby, the file ‘twrp-3.3.1-0-s2.img’ must either be in the same directory as "FASTBOOT or it must be included in the list.

fastboot flash recovery twrp-3.3.1-0-s2.img
… or …
fastboot flash recovery <partition> [ <filename> ]

zum Beispiel: fastboot flash recovery /LeEco/twrp-3.3.1-0-s2.img

Hallo @archje,
hm… wie sorge ich denn dafür das die TWRP file im gleichen Verzeichnis wie FASTBOOT liegt oder wie baue ich sie in die Liste (welche?) mit ein?

Rätsel über Rätsel… :confused:

Hi @archje,

hm, how do I include the TWRP file in the same/right directory as FASTBOOT or how do I include it in the same list (which one?)?

Puzzle after puzzle… :confused:

Hello @bixxby,
after you’ve downloaded the SDK Platform Tools package where did you extract the contents of the ZIP file to?

By the way: Which operating system does your desktop PC work with?

Hello @archje,

I’m running Arch Linux on my Notebook.

I didn’t download the SDK Platform Tools from a 3rd party website but from the software choice my OS does offer. It’s been installed in the /home directory.

1 Like

While this is obvious, but it isn’t always ideal. What version of ADB & Fastboot has your Arch Linux system installed?

My fastboot version 29.0.5-5949299

By the way: The 3rd party website linked above is from G°°gle developers.

And mine is Version 29.0.5-5949299, too!

Installing and using ADB and fastboot on Linux and setting up → adb fastboot guide

this reads much too complicated to me, might be easier in my native language. :disappointed:

So, thanks a lot for your efforts, I think I change to buy one of the Samsung S9 phones with preinstalled
/e OS.

Anyone interested in my LeEco Le 2 (X527)? A rugged case and 3 anti-glare screen protectors would be included…

Michael, you can also join the German group to participate. Here’s how it goes…

Michael, Du kannst auch der »Deutschen Gruppe beitreten um mitzuwirken« So geht’s …

Hallo archje,
danke, kenn’ ich schon, bin ich auch. Allerdings ist die Anleitung für ADB und Fastboot von Lineage
auch da nur in Englisch verfügbar… :+1: :wave:

Hello archje,

thank you, I know the group, I’m a member of it.

But even there the tutorial for the usage of ADB and fastboot is only available in English. Although I’m not bad in that language (I was working in the airline business for more than 25 years) I’m not that good to understand the technical wording.

How about now? Where do we go from here?

Frankly: I have no idea.

I’d like to leave the world of Goolag but as my technical knowledge seems to be too limited and I do not have any people around having more expertise than me (my friends/family are not that sensitive about the “dark side of the power”) I’m at a loss for now.

I’ve to think about what to do now. It seems to be the best for me to buy one of the Samsungs /e offers. Or I’ll wait until the /e installation service is available, as my LeEco is brandnew…

Do you know more about that?

About the /e/ installation service Mail-in also knows only what was spoken here.

So far, there has only been speculation about the administration fee. Probably in the range of € 50 plus up. Whether this “discussed” amount already includes packaging and return shipping - I have no idea.

This is probably the state of affairs: Mail-in your phone is in beta testing!

Regarding the Mail-in flashing service, it is still in evaluation but has proven much more complex that what we were initially planning. The main challenge being devices versions vs what we support and can operate.

At the same time, we have made great progress with our easy installer and plan to roll it out very soon.

@rhunault can you give this thread a look and maybe have someone help @bixxby to solve his issue setting up /e/ on his device?

@bixxby can you confirm your device model is the “X527”?

Hi @bixxby,

If I understand, you already have a recent version of Android tools, which should be enough to run the install.

Could you please let me know where is stored the twrp-3.3.1-0-s2.img files?

Thank you in advance,


Hi folks,
thanks a lot for taking so much care of my problems, I really appreciate that… :smile: :+1:

@archje: ok, I think a fee of about 50 € plus shipping would be fair for me. Let’s see what’s coming up on that issue.
@alexis: yes, according to the manual and the backcover it’s the “X527”. I’m really looking forward to the “easy installer”…
@rhunault: I stored the TWRP files in the internal storage of the phone, “next to” the folders “Alarms”, “Android”, “DCIM” etc.

The TWRP file have to be on your computer. Once download, then you will be able to run the command:

fastboot flash boot /path/to/twrp-3.3.1-0-s2.img

@rhunault: Aaah, I didn’t know that…

So, I did download the TWRP-image to my notebook and stored it in the /home directory. Then I ran your command and got the following error message:

[scheff@scheff-pc ~]$ sudo fastboot flash boot /home/scheff/twrp-3.3.1-0-s2.img
Sending ‘boot’ (24618 KB) OKAY [ 0.915s]
Writing ‘boot’ FAILED (remote: ‘Partition flashing is not allowed’)
fastboot: error: Command failed
[scheff@scheff-pc ~]$

What went wrong?

OK, new information: I looked up the internet to find a solution myself and I think I made it. Now I have the following message in my terminal window:

[scheff@scheff-pc ~]$ sudo fastboot flash boot /home/scheff/twrp-3.3.1-0-s2.img
Sending ‘boot’ (24618 KB) OKAY [ 0.928s]
Writing ‘boot’ OKAY [ 0.196s]
Finished. Total time: 1.128s
[scheff@scheff-pc ~]$

And what’s next? The device is in recovery…