[SOLVED] Still having problems with installing /e on my leeco le 2

Hello archje,
soryy I don’t understand that. When the device is in recovery why and how do I reboot into recovery? :confused:

The above points are taken exactly from the /e/ documentation

6.) Now reboot into recovery to verify the installation.

WinTeam TWRP > Main menu > tap button Reboot > tap button Recovery

Yeah, I read that part of the documentation, quite confusing to a beginner like me…

So, the screen of the phone only shows the LeEco logo and under that the word Recovery. Do I have to remove the phone from the Notebook? And how do I get to TWRP?

That doesn’t sound right from a distance. A picture would be helpful.

Boot Modes [/e/ documentation bottom right]

Recovery: With the device powered off, hold Volume Up + Power.

Download: With the device powered off, hold Volume Down + Power.

Ok, here’s a pic of the screen…

This looks more like StockROM Recovery. In any case, yours isn’t WinTeam TWRP Recovery.


And now?! Dissatisfying… VERY dissatisfying…

I’m dissatisfied too.

How long does ADB Sideload normally take?

It appears that the correct sequence of installation steps has not been followed. This is why WinTeam TWRP Recovery was not installed.

It is very important to restart immediately after installing the custom recovery.

6.) Now reboot into recovery to verify the installationd

Otherwise, the WinTeam TWRP Recovery will be overwritten by StockROm Recovery and the device will be restarted.

ADB Sideload only works properly with TWRP Recovery.

TWRP is installed but fails to start the ADB Sideload process. Any advice?

Do I have to start ADB Sideload only on the device or also on the Notebook?

ADB Sideload must be operated on both devices …

Ok, understood…
When I start ADB Sideload on the Notebook I get an error message:

[scheff@scheff-pc ~]$ sudo adb sideload e-0.7-n-202221541379-dev-s2.zip
[sudo] Passwort für scheff:
adb: failed to stat file e-0.7-n-202221541379-dev-s2.zip: No such file or directory

Another advice avalable?

As for TWRP, you must provide full path for the zip file :wink:

If the files to be transferred aren’t in the same /directory aka /path of ADB & Fastboot tool, additional /path information must be given so that they are transferred from ADB & Fastboot Tool.

/e/ documentation
Install /e/ on a LeEco Le 2 - “s2”
Installing /e/ from custom recovery

8.) Sideload the /e/ (e-0.7-n-*).zip package:

8.1) On the device (LeEco Le 2 X527), select “Advanced”, “ADB Sideload”, then swipe to begin sideload.

On the host machine (Arch Linux Notebook), sideload the package using:

8.2) $ adb sideload /**path**/**to**/e-0.7-n-202221541379-dev-s2.zip


9.) Once installation has finished, return to th WinTeam TWRP main menu, tap Reboot, and then System (see also images posting #27)

Hm, still not sure “where to go”…

I have a folder “Android” that contains a folder “Sdk” and that contains nine more folders named “build-tools”, “emulator”, “patcher”, “platforms”, “platform-tools”, “skins”, “sources”, “system-images” and “tools”.

I copied the files from the folder “platform-tools” into the folder “home” so the path would be

$ adb sideload /home/scheff/e-0.7-n-20222154379-dev-s2-zip

Error, “no such file or directory”…

So then I copied the /e Image into the folder “platform-tools” and changed the path to

$ adb sideload /home/scheff/Android/Sdk/platform-tools/e-0.7-n20222154379-dev-s2-zip

Error, “no such file or Directory”…

Any more suggestions?

Yes, the file is not there. So be sure you have the correct path:
find -iname e-0.7-n-20222154379-dev-s2-zip 2>/dev/null
Now the full path must return otherwise the file is not there or you have the wrong filename.
If the full path is found, use that in your sideload command.

Hi andrelam!

I followed your advice and got a “empty” answer:

[scheff@scheff-pc ~]$ find -iname e-0.7-n-20222154379-dev-s2-zip 2>/dev/null
[scheff@scheff-pc ~]$

But I did download the /e image? The file is definitely in the /home directory and I did not change its name…

WHOA, wait a minute!!!

When I follow the link to the Download from the install instruction page the image is named


Where do you get your file (e-0.7-n-20222…) from?!

Installation alternative WinTeam TWRP

  1. Download the file → e-0.7-n-2020021541379-dev-s2.zip with your Arch Linux Notebook

  2. Boot into TWRP Recovery

  3. Copy the file → e-0.7-n-2020021541379-dev-s2.zip into the Internal Storage of the LeEco Le 2 X527.

  4. Now tap “Install” and select the file 0.7-n-20222154379-dev-s2-zip from the Internal Storage

  5. If TWRP message … done … tap “Dalvik / Art Cache” swiping appears and the system is rebooted and initialized.

That should be it then!

Download /e/ for s2 * dev (nougat)