[SOLVED] UBER / issues with Map & trip visualisation

Hello,
I installed UBER on /e/ 0.5-201903194697 on Essential PH1.
I face some issued on the trip visualization as well as the pickup point selection tools which just don’t appear on the screen.

Any way to solve it ?

PS: I know… uber is evil… but still for some local reasons, I wish to use it (even on /e/)

2 Likes

It could be an issue with MicroG. You can try using the LineageOs4MicroG ROM and verify if the behavior is the same there as well. Alternately raise a bug on Gitlab with logcat.

1 Like

Can you use UBER with /e/ ?
I am the only one having this problem?

I had tested this some time back and had experienced the same issue. After reading up quite a bit on microG’s implementation of the Google Maps API, the issue seems to be caused due to that. They (microG) have gotten many parts of the API working but some parts don’t work yet.

Uber seems to kinda work but doesn’t show the start/end point and cabs on the map. Booking a cab should work correctly. Unfortunately, other apps such as Ola and Lyft don’t seem to work at all.

1 Like

Thank you. Let hope it get resolved :wink:

(En Français ci-dessous)

Hello there ! I have the same issue. Has it been resolved ?

My apps are almost all working well with Micro G. Almost ! Indeed, Uber, Taxify and Lyft, that provide all basically the same service, are not working. With Uber, I can order for a car, but I can’t see the map, so I cant check if the locations I indicate are correct. With Taxify and Lyft, I can’t even order a car. Taxify says it encoutners problems with Google Play Services, but Self-Check in Micro G is ok.
Also, the RATP app (Paris transport app) isn’t working.

Do some people have the same issue ? Any idea how to fix it ?

In the meanwhile, I found another app, Yango, similar to Uber and working, but as it is new, they don’t always have cars available.

thanks in advance for the help.


Bonjour vous ! J’ai le même problème: a-t-il été résolu ?

Mes applications fonctionnent presque toutes correctement avec Micro G. Presque! En effet, Uber, Taxify et Lyft, qui servent toutes à la même chose, ne fonctionnent pas. Avec Uber, je peux commander une voiture, mais je ne peux pas voir la carte, je ne peux donc pas vérifier si les emplacements indiqués sont corrects. Avec Taxify et Lyft, je ne peux même pas commander une voiture. Taxify dit avoir des problèmes avec Google Play Service, mais le Self-Check dans Micro G est tout coché de partout.
L’appli RATP ne fonctionne pas non plus.

Certaines personnes ont-elles le même problème? Une idée de comment y remédier ?

En attendant, j’ai trouvé une autre application, Yango, similaire à Uber et qui marche, mais comme elle est nouvelle, il n’y a pas toujours de voiture disponible.

Merci d’avance pour votre aide.

1 Like

Hi @Pistou and @Nana,
you might want to try using the progressive web app (PWA) of Uber instead of the Uber Android App. See a link below.


You will get access to localization (see cars, set your pick up location, check your destination) without having to download or fake GMaps as the PWA works with the browser and not the Google Play Services.
I hope this helps.
Best regards.
Alexis

8 Likes

Thanks, i wil try and let you know

Similarly, I use browser Lyft (on my pre-/e/ phone) - it is not easy to find as Lyft discourages it, but it has been a way to get a rideshare without downloading an app, and I am hoping this will be a workaround to the MicroG GoogleMaps issue.

1 Like

Problem solved with Dec 2019 update.
The new version allows Uber to run, and it access Open Street Map. Cool

1 Like

Some light reading about Uber and Reasons not to use it… https://stallman.org/uber.html

1 Like

Thank you Alexis for sharing that there is a PWA for Uber.
It works almost fine.
It cannot find my own location. I gave access to the browser to request and access my location, but doesn’t work.
Anyone also experiencing ‘location error’ issue?