[SOLVED] Unable to install 0.2 on S9

Hi all

I’m not that familiar with rooting Android devices.
I’ve been able to follow the outline in the wiki. Currently I have been able to boot into twrp and wiped both data, cache and system and then rebooted again into twrp. I’ve downloaded e-0.2-201812222301-nightly-starlte.zip onto /sdcard/.
When I try to install it ends with error 7 (see enclosed pic). Vendor image on the device is NOT compatible.

Model of S9 is SM-G960F/DS

Any help appreciated.


Did you find a solution?
Can you give more pictures with the différents steps?

@foo8ar Please can you share the current build and os version of your device. The build on which you are trying to flash the /e/ ROM. The TWRP error comes on flashing incorrect ROM version so just wanted to check which firmware version is currently on your device.
Looping @rhunault on the issue

Hi @foo8ar,

Could you please tell us if you are facing the same issue with an official LineageOS package (https://download.lineageos.org/starlte)?
Thank you in advance,


Hi @foo8ar are you still facing this issue with installing ROM’s on your S9

Hello everyone, today I flashed my S9 dual sim.
I was using stock ROM before, with magisk root. I had the the same problem.

  1. I flashed this : G96XF-FD-N-CSE3_by_SoLdieR9312_18.0_r73.zip but it did not work.

  2. I then flashed this VENDOR-27_ARI9.zip and it worked. I just followed the sortened link you can see on the screenshot. Maybe this could be add in installation tuto here : [HOWTO] Installer /e/ sur un smartphone Samsung avec Windows facilement and here https://gitlab.e.foundation/e/wiki/en/wikis/device/starlte/install

1 Like

Hello @Nathanael,
I’ve the same issue with my new Samsung S9+ when flashing the e-0.6-o-2019060812705-dev-star2lte.zip with TWRP and following the [howto] french guideline. (I’m newbe in flashing ROM, my very first time).

When you say that you flash the VENDOR-27_ERI9.zip and it works, that it means that you’ve also flashed your eOS zip file after ?!

thank you for your help

Yes I flashed /e/ ZIP after vendor ZIP :wink:

Thank’s. I did it and it succeed to flash both.
But when rebooting, after the e logo, I receive a message like “encryption failed, need to reset default factory. data will be deleted…”. No choice so I did It and by smartphone start to reboot continuously : boot -> e logo -> reboot -> e logo -> reboot…
I stop it by reentering in recovery mode.
Any idea ?

OK I get the solution. Please see in this post continuous-samsung-reboot-after-encryption-failed-need-to-reset-default-factory

Mmmmm I think you should wipe internal storage in twrp. It would erase all jour data and disable encryption. Can someone confirm ? @rhunault @pundirsumit ?
Edit I read only thé first of your last messages. Sorry and happy you found by yourself

1 Like

Yes this is the solution, for most of Samsung devices.

  1. Boot into Recovery
  2. Wipe > Advanced Wipe
  3. Tick Data and tap Repair of Change File System
  4. Change File System
  5. The choice here depends of the devices (it’s EXT3 on Galaxy S7)

In addition, if you want to encrypt your device with /e/, you might need to resize Data partition.

  1. Boot into Recovery
  2. Wipe > Advanced Wipe
  3. Tick Data and tap Repair of Change File System
  4. Resize file System

Resizing file system can be done latter, without data lost (a backup can anyway be useful).