[SOLVED] Update /e/ or not update /e/?

Hello @bauduen, the S7 currently still runs with /e/ OS 7-nougart. Since there are no official Android security leases since last year, the /e/OS Build Team has to do a lot of work to generate security leases from higher Android versions (8.x / 9). So it may still take some time.

However, there is a little bit of hope: /e/ OS 8-Oreo has been tested for the S7 / S7 Edge for two months. Improvement is coming in small steps …


Hello @archje, thanks a lot for your explanation - and thanks a lot to all of you at /e/ for the fantastic work you’re doing!

Hm, that’s weird. Maybe it’s because you unistalled a lot? :joy: I wonder if my process is right? I use the /systemapps remover app from f-droid, convert those I’d like to uninstall into normal apps, them I directly unistall them from launcher…

I only test rooted devices in exceptional cases (never really), and almost never with a remover app or remover script.

adb shell uninstall <name> (remove the app)

reliably removes one app after another with instant feedback. Meanwhile, this only takes a few minutes for me.

1 Like

Good, thanks for that. Gotta mess up with that good old terminal! :grin:)

Yeah. but you know and see what you do.

Hi there,
I have an other issue, since january I have no updates found. I’m on a samsung galaxy S7 which I bought with /e/ pre-installed.
Is it normal ?
Thank you

I will (or somebody else) tell you if it’s normal or not.

Hi @Xyguma the stable builds which go on the phones we sell through the eStore are released less frequently. This is when compared to the normal development builds. We are currently testing a build and there should be an update in the next couple of weeks on the stable branch.

I’m a S7 “dev” user and until today I only have the Android security patch level from February 5, 2020.

Pl can you check what is the latest security patch for the S7. Normally the builds picks up the latest patch from upstream. If there is a newer version of the patch and it is not reflecting pl let me know and I can have that checked.

Samsung has rolled out the April 2020 update of Android™ Security Updates for the first Galaxy smartphones. The patch fixes 14 critical and 39 high security vulnerabilities. Please see also Android™ Security Bulletin - April 2020.

1 Like

Thank you very much, it clarifies a lot, I didn’t know. Thank you

1 Like

In the meantime even a fantastically well working but unofficial /e/ OS ROM 9-pie was built. Unfortunately, it will remain a flash in the pan, as it is not intended to be used as a basis for further development or even monthly security patches. Sad story …

1 Like

Thanks a lot for update /e/OS 0.9-2020062860623 for S7 - just installed it and so far it works great! Only one problem remains: Rotation seems to be connected to adaptive brightness, it only works properly with every app if that is switched on (I hope I’m in the right thread with that…).

I have a SONY XPeria XA2 and I got /e/ to function quite well on it.
I even did some updates.
But I put it aside for two months until last week when I took it again and
had the unfortunate idea of updating it…
I took the last one, downloaded it then reboot etc.
However, since then I’m unable to boot it : it gets stuck with the “e” logo
and the moving dot.
I’d rather find a way to get it back to a better state without wiping it :slight_smile:
If anyone has a suggestion, I’d be glad to read it.

First, try to reinstall the last version by downloading it and installing the zip file via TWRP (like for the first time).

If it doesn’t work, do the same thing but with the last working version.

If it still doesn’t work, maybe you don’t have enough storage space and the installation can’t be completed. If it’s the case, try to use “adb sideload” on a terminal and go to TWRP > Advanced > Sideload, or try to delete some of your files via TWRP > Advanced > File manager.

Thanks. I’ll try and do that.

In the end, I had to wipe data and it finally booted normally…
I’m positively sure there were still at least 10 GB of space on the device [I always check this]. Anyway, I’m back with a fully functional phone but slightly annoyed to have to set it up again.

Since the previous issue, I already updated successfully my XA2 once.
Just in case, I hadn’t install anything, simply configure two mail accounts, just to be sure the system has plenty of space.
This week I decided to install the last update. Again the phone was not able to boot anymore and I had to wipe data again. This time I can say it was a bare system (and an empty SD card as well). It even was quite tricky to boot in recovery mode and wipe data (I had to keep pressing the volume and power buttons continuously while trying to select the wipe data option with the other hand).
Knowing a simple update may force you to erase and reconfigure everything doesn’t encourage me to continue using it.