Sony Xperia XA2 (4113) Fingerprint Reader no longer functional in Android 10/11

Hi forum,

I recently ruined my e-os Android 8.1 Build when I was updating to the last e-0.20something version. After I quit swearing I decided to go for the latest 1.3 R or Q Build an had the same old trouble as wireless, bluetooth and GSM service was not available (strangely in both boot slots a&b). I got this sorted out by going back to a stock(ish) ROM with EMMA and have R-version (Android 11) now running quite ok, but the much loved fingerprint reader is gone. I read in some articles that Sony has the same issues with its recent models and Android 11 on their official releases.

Can anyone give a hint whether this can be fixed in the near future or whether I should say goodbye to this feature and live without it.

Kind regards and thanks to the e-OS / Murena-Team for making this de-googled OS happen!

Silvan

Fingerprint works fine on XA2 latest builds eOS Q and R.

You say you returned to stock-ish via Emma. Not sure what you mean by that but you should have chosen an Android 9 version with the numbers 50.2.A in the description and gone for the full content software erase option (something like that, from what’s left of my memory).

It is important to follow all the steps in the install instructions after a restore on Emma. If you miss the copy partitions procedure you could end up with firmware related problems or worse.

You say the fingerprint reader is gone. Could you be more specific? Is it listed in the settings app?

If you have followed all the steps correctly it may be hardware related.

Hi chris, thanks for looking into this issue.
As suggested I installed Android 9 50.2.A with deletion of all content. Everything was working well (phone, wireless,BT and the fingerprint reader).

I had some trouble to get into a state from which I could run the copy-partition-script. I had to flash the e-recovery to both slots. Now the phone always went into this error-message that it is corrupt and will power down in 5s.

Now I am about to flash e-r and see how it goes. Did I already cause a major problem going this way?

And yes, the fingerprint reader is completely gone, not showing as a device, neither being suggested with the security measurements.

Kind regards

Silvan

Ok, this did the trick. After sideloading the latest r-build the system booted up fine, fingerprint reader worked an it even remembered my fingerprint…spooky.
How are your experiences with OTA-Updates? Is there going to be this a/b trouble again? How would you get a backup of your device, now it’s running so well?

Thanks for your input.

Silvan

PS: After installing the stock-version with EMMA I really had problems with the adb connection in Windows. On Ubuntu, it’s all like a charm.

I don’t know what’s going on with your phone! Are you following the eOS installation instructions, step by step?

Anyway, you got it working so hopefully it’s ok.

Backups not so easy, but there are some posts on the forum somewhere about backing up with abdb. I’ve tried it in the past with some success. If I find the post I’ll let you know.

OTA’s are normally OK, but if there is a total mess on the other slot it may cause problems. Next time you do a manual install don’t install the latest rom version, go for the penultimate version. You can then test OTA’s immediately on first boot.

EDIT Here’s the post I was thinking of for backup with scripts and adbd , and the entire thread is a valuable resource too.