Sony Xperia XZ 1 compact

Looking for regular support of Sony Xperia XZ 1 compact.
My mobile has still warranty. I am planning to unlock bootloader in the beginning of 2020. After this I can start testing.

1 Like

Hi, If you succeed of doing this, I’ll be very interested to try /e/ OS on my Sony Xperia XZ1 compact as well, so please tell me :wink:
Thank you

I’d love to see this device supported too

Hello, i’m also interested to see /e/ OS on XZ1 Compact !

There is an unofficial LOS 17.1 build for this device

Also, this device is available in Sony’s Open Devices program and they make available in their github repos the needed device configs and binary blobs for making builds.

I hope this information helps to get a device-specific /e/ build for this device sometime soon :slight_smile:

Hi @petefoth, I tried the LOS17.1 for lilac (XZ1C). The first tests are successful.

Hi @Unknown, could you please build /e/ for lilac as you did it in the past for the suzuran? All your tips to build it on my own do not work, because I don’t have enough space and enough power on my machines. I now have a working LOS17 on lilac, but I finally want to go on /e/, before investing too much time in configuration.

LIke you, I don’t have the resources to build on my own machines. This thread has details of how you can get free credit to build in the cloud, using’s cloud compute instances or Google Cloud Platform.
I made several build using, then moved to OVH who were also offering free credit.

Thank you, I tried the howto from unknown with The case with the deposit did not work, but all the same it is not so expensive, so I continued. I am using XUbuntu 20.04 with its putty. I chose the biggest and fastest server. All worked until docker gave an error like “repository name must be lower letters”. It can’t be in the command I copied, so it must be deeper. As you wrote, that it works for you, it must be me, who did something wrong. Do you have any idea?

I have done all my builds with Ubuntu 18.04. I know other people have had problems with later versions, so maybe worth trying 18.04 instead of 20.04

Hi petefoth,
I had someone, who tried it from an Ubuntu 18.04, which also brought the same error message with my string. Later I checked the command string and detected something, where I deleted a letter while entering my phone parameters. That was the fault. I corrected it, but now I have another error message after some minutes, where a string is expected instead of bytes. I will continue, but I would prefer, if someone who succeeds in building would make me a new one for lilac.

Me too :slight_smile:

Hi @petefoth,
now I tried both on vultr and locally to build an /e/.
Didn’t have luck. I did it according the howto of harvey186, I tried it for unofficial lineage-support or without lineage and without docker. I had syntax problems, references which overtook each other. I had version conflicts. I tried to flash GSI coming from an AOSP, because flash of stock rom did not work.
Every time boot-loops.
Thank god, TWRP works fine as live-saver for my lilac.
I don’t want to continue with lilac now. It is too time-killing. I’ll wait for full support of lilac.
What works fine, is Lineage 17.1 or/and AOSP, so I’ll use LOS.
Thanks for your support and I am looking forward for the build for lilac of other guys with more luck.

1 Like