Sony Xperia Z5 compact (suzuran)

I truly appreciate you all. I apologize for the late response. I’m going to try again right now with TWRP 3.2.1. I will post an update. The problem is that the recovery never loads… It simply goes right to Sony screen then onto loading the Android OS.

padreadamo@padreadamo-suse:~/Downloads/Phone> fastboot flash recovery recovery_suzuran_220218_2.img
Sending ‘recovery’ (12008 KB) OKAY [ 0.318s]
Writing ‘recovery’ OKAY [ 0.121s]
Finished. Total time: 0.485s

I unplug USB… hold power and vol down and the white sony screen, then android boots… no recovery.

Tried to Flash the 3.5.0 as well:
padreadamo@padreadamo-suse:~/Downloads/Phone/TWRP_3.5.2_9-0-recovery_suzuran_2021-04-11> fastboot flash recovery TWRP_3.5.2_9-0-recovery_suzuran_2021-04-11.img
Sending ‘recovery’ (22532 KB) OKAY [ 0.590s]
Writing ‘recovery’ OKAY [ 0.213s]
Finished. Total time: 0.850s

Unplug phone from fastboot mode (blue led black screen)… hold power and vol down… boots to sony and then Android.

Please tell me that you mis-typed . This ROM is for a Sony device (Xperia Z5 Compact, codename “suzuran”. If you try to install anything built for this device on a Samsing device, then nothing will work!

Mistype… sorry long days at the hospital.

Then I’m sorry, I can’t help any further. That process has always worked for me. I don’t know what else to suggest

I appreciate the help. It is what it is.

If it may help : [TWRP][E5823] Latest TWRP 3.2.1 for Z5 Compact | Page 7 | XDA Forums

Thanks for that @smu44. From those posts, it seems that it is important to have the latest Nougat stock firmware installed. I’ll go back to my notes from last year when I first started installing custom ROMs on my Z5C. I’ll be back…

OK. A couple of questions:

  1. Are you still able to boot into Android (i.e. the unchanged Sony software)?
  2. If so, what information does it show when you gp into Settings | About phone? In particular, the fileds Android version and Build number
  3. Have you ever run Software Update from that Settings page?

I just received it. I can boot no problem. Phone works just fine when it comes to just using the OS it came with (Android 5.1.1). I ran software update and never received one; it states, “Your device is up to date.” Here is the information:

Model: E5803

Android Version: 5.1.1

Kernel Version: 3.10.49-perf-g83fc9bc
BuildUser@BuildHost #1
Tue Oct 13 05:33:30 2015

Build Number: 32.0.A.6.152

I think this is the problem. You need to have a more recent version of Android for TWRP to work.
To do this, you will need a tool to flash up-to-date software

  • First thing to try is the official Sony tool (called Emma. It’s Windows only, so if you don’t have a windows machine then ignore this step). Download from here, install and follow instructions. With luck it will find and install a more recent Android version for your phone.
  • If Emma doesn’t work, then your next steps are to use tools called Xperifirm (which finds and downloads the correct firmware for your phone), and FlashTool, which flashes the downloaded firmware to your device.
    Instructions for using Xperifirm are here
    You may be able to avoid using Xperifirm, by downloading the firmware directly: I found what appears to be a trustworthy version from here. Ironically the download link takes you to a Google Drive folder :slight_smile:
    Detailed instructions for installing and using Flashtool are here

Please be aware that this is a very fiddly process: it is easy to get things wrong and get your device into a state where it won’t boot at all except into bootloader mode. It is almost always possible to retrieve the situation but it can be very frustrating and may take up a lot of your free time! If you do decide to go ahead, then good luck! And I will try and answer any other questions you may have, or suggest ways round any problems you run into. But it may take me a while to respond

Success for Emma!



Same Android version - 5.1.1

Kernel Version: 3.10.49-perf-g75e6207
BuildUser@BuildHost #1
Mon Oct 26 23:20:48 2015

Build Number: 32.0.A.6.200

Flashed using Flashtool and downloaded the custom firmware of android 7.0… success! I’m working on Fastboot and recovery now… tested boot and turned on USB debugging after install of 7.0

1 Like

/e/ is succesfully installed and running!
0. I believe the Emma step could have been skipped because using the 7.0 Firmware link and Flashtool brought me up 7.0 which Emma simply brought me up a subversion of 5.1.1.

  1. Had to use the firmware link and use Flashtool on WIndows to flash Android 7.0

  2. Had to boot into phone and enable USB debugging / OEM unlocking (if it wasn’t)

  3. Used Fastboot to flash the twrp recovery version 3.2.1 -

  4. Booted into recovery, HOLD POWER BUTTON AND VOL. DOWN

  5. Followed the rest of the instructions per /e/ install for Sony Experia Z5 Compact

I want to personally thank @petefoth for getting through this Journey with me. He was patient, kind, and without him this would not have happened. I only ever owned Nexus 5x devices. But because of the bootlooping on those I have gone through 2 a year and can no longer do that.


I suggested using Emma in the hope it would pick up the update to 7.0 and you wouldn’t have to 'get your hands dirty` with FlashTool. I’m pretty sure that my device got OTA updates to Android 7 from Sony, but it was a long time ago :slight_smile:

Anyway, great that you’ve got it working - have fun!


This is awesome! I watched and tested Berhards Roms a lot. To see know that /e/ is running on suzuran is nice.

And it works really good. Perfekt!

HeY. I am new here and my english mightbe little bit poor But I have a problem to “Boot a custom recovery from fastboot mode” that looks like this:

~$ fastboot flash recovery TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23
fastboot: error: cannot load ‘TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23’: No such file or directory

I use linux mint. I have entered fastboot mode, but I can´t flash the recovery image!!!

From what you have typed, the problem seems to be that you have not given the full filename of the recovery image to be flashed. The file you need to flash is called TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img, but your build command does not contain the .img suffix.

If you have downloaded the file from here, you should have a file called TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23 .7z in the directory where your browser stores downloaded files. That file is a compressed zip file which contains the .img file you want, so you need to extract the .img from the downloaded .7z file.

The easiest way is to double-click on the file in the Nemo file manager, which will open it using the Archive Manager.

You will see the compressed .7z file contains two files: TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img and TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img.md5.

In Archive Manager, extract the file TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img to a working directory (e.g. ~/twrp)

In terminal, go to that directory cd ~/twrp

Now you can run the fastboot command fastboot flash recovery TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img


Thank you very much answering. But I am not a easiest pupil in this school. I got this result, so I did not learn “how to” in the first lesson…

jiimintti@jiimintti-Latitude-E6220:~$ fastboot devices
CB5A28Y8SF fastboot
jiimintti@jiimintti-Latitude-E6220:~$ fastboot flash recovery TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img
fastboot: error: cannot load ‘TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img’: No such file or directory

So still the same result… I am also poor using terminal and my mint-pc.
May be the path to this file is not correct.
I did not quite understand this: " In Archive Manager, extract the file TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img to a working directory (e.g. ~/twrp)". I have already extracted the file to “downloads”. Should I make new directory “twrp” and remove the extracted file TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img there? It is already extracted, should I somehow extract it again?. Or should I write the path to directory “downloads” or “twrp” in a dierent way?

OK. The key is that you have to tell the fastboot flash ... comand exactly where to find the img file.

In the fastboot flash ... command as it is, you are saying ‘flash the file called ‘TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img’, which can be found in the current directory’. The file isn’t in the current directory, so the command fails.

If you have put the extracted file in your Downloads directory (in mint this is usually /home/yourusername/Downloads, which can be shortened to ~/Downloads, where ~/ translates as ‘in my home directory’.

So the easiest way is to navigate to that directory (cd ~/Downloads) and then run the command again, which should succeed, because the file is in the directory where you are running te command.

Or you can stay in the directory you are currently in, and pass the full path name of the file to the command, so
fastboot flash recovery /home/yourusername/Downloads/TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img
or maybe
fastboot flash recovery ~/Downloads/TWRP_3.7.0_9-0-recovery_suzuran_2022-12-23.img

Again, the command should succeed because it is looking for the img file in the correct place

So, thank you for good advices. Inspite of them, something went wrong, and now I have a phone that does not react but have the white screen with SONY logo on it, after I dried to “adb sideload” image to phone three times…
May be this was too complicated for me…

I found a way to return to recovery mode and I try to install /e/, but no succes. Again I do something wrong because pc does not find the file /e/.

FROM THE TERMINAL (Here finnish word Lataukset is Downloads)

jiimintti@jiimintti-Latitude-E6220:~/Lataukset$ adb sideload /~/Lataukset/to/
adb: failed to stat file /~/Lataukset/to/ No such file or directory

jiimintti@jiimintti-Latitude-E6220:~$ adb sideload ~/Lataukset/
adb: sideload connection failed: closed
adb: trying pre-KitKat sideload method…
adb: pre-KitKat sideload connection failed: closed

jiimintti@jiimintti-Latitude-E6220:~$ adb sideload ~/Lataukset/
adb: sideload requires an argument
jiimintti@jiimintti-Latitude-E6220:~$ adb sideload ~/Lataukset/ e-1.8.1-r-20230206257804-dev-suzuran
adb: sideload requires an argument

So, still have some problems…