Sony Xperia Z5 compact (suzuran)

Joining the request for an official build for Sony Xperia Z5 Compact.
I’ve tried on a supported phone (Moto E) and I would love to have /e/ on my ‘daily driver’
Thanks for all you efforts

Hey all!

Joining my interest for the Sony Xperia Z5 Compact. I have used the 0.9-n /e/ unofficial build on it for a few months now, and have had little to no issues as my daily driver.

This is one of the last sub 5-inch screen devices from what I can tell, and I want to ensure that it remains usable in the future. I am interested in becoming a maintainer for this device to ensure its support.

For incoming users, see @Unknown’s post for the link to the topic of the latest UNOFFICIAL BUILD.

The problem is that there is no LOS16 nor a LOS17.1 rom officially.

Here is some progress but far away from official los:

But there are unofficial /e/ builds (see this thread), and there have been for quite a while. They build without any changes to the /e/ source or build tools so, arguably, there is no need for LOS support.

Fingers crossed that an official build emerges, but the unofficial builds are good enough to use until it does (IMHO).

I also want to join the request for an official build for this phone… Would be great to run /e/ on my Sony Z5 compact :slight_smile:

I also want to join the request for an official build for this phone. The Sony Z5 Xperia F531 compact is a good little phone.

Hi @GoAnna

Just in case you haven’t found it yet, there is a fairly up-to-date unofficial build available. Please see this thread

This device is now officially supported. :slight_smile:

e-0.15-q build, along with installation instructions is available here


It seems the build for suzuran is not accessible. Trying to access I receive a 403 “Forbidden” Error: “You don’t have permission to access /dev/suzuran/ on this server.”
Please fix soon, I’d love to give the Z5C a try!

Sorry about that. It should be fixed now. Please try again.

1 Like

Good evening,

I have unlocked this phone successfully and enabled USB debugging. I have working ADB and Fastboot. However, even after successful flashing recovery… I can’t boot into recovery. Anyone having this issue? I used /e/ for several years on Nexus 5x… but I needed a more reliable device. Please help in anyway you can.

This is an E5803.

How are you trying to boot into recovery? I know of two ways

  1. If your phone is in bootloader mode then fastboot reboot recovery
  2. Power off the device and disconnect from your PC, then hold the ‘Volume down’ key and press ‘Power’ key.

If 1 doesn’t work, try 2

I have performed those combinations many times…no go. Apparently I need to flash a custom kernel to chain load into recovery? I read this on XDA.

You don’t need a custom kernel. What recovery have you flashed?

Z5 compact just shows you black screen on bootloader, but the led light is blue. Then you need to flash twrp to your recovery and then you can open it. When phone is off, press power and volume down until it starts.

And you maybe have the wrong twrp version, I had the same problems but little bit of searching I found right version of twrp. It was something like 3.2.something

According to xda the required version is TWRP 3.2.1

3.2.1 worked for my Z5C.

1 Like

I’ve never shared anything from /e/ cloud before, so this may or may not work, but here is twrp 3.2.1

This is the recovery you need

TWRP image for suzuran, built by Bernhard Thoben ( Professor-Berni on github, Berni-0815 on XDA forums), and uploaded by me to AndroidFileHost so that there is a direct link to the correct version :slight_smile:

The XDA forum thread for this recovery is here. Please follow the instructions on that page to install and boot it on your device


Cheers @petefoth, spot on advice as usual.

:slight_smile: @Manoj is also going to update the install page of the documentation so that it has correct instructions and links to the correct version of TWRP.

1 Like