Stopping dropped calls on Mint Mobile

This seems to happen when the phone is asleep, and my installing Visual Voicemail may have something to do with it.

I get no ringtone and no alert that i have a voicemail.

just wondering if there are some settings i should check before i settle in for a long chat with Mint customer service and maybe go back to ATT.

I have power cycled the phone and reseated the sim card a couple of times.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Update: Have had a couple of brief chats with Mint tech support. They have asked me to switch to 2G, which disconnected the first chat, and enter a code to stop forwarding voicemail, which seemed to have no effect. They’ve escalated the ticket.

These settings will not save. Phone always boots back into the “ting” setting, which does not work.

did you or support setup any of those new APN entries? and… if you compare them, are mcc and mnc numbers the same in all entries?

maybe it’s worthwhile to ping the mint mobile threads that exist to day if users with mint mobile experienced what you describe

can you mention on what version you are and phone?

No, neither i nor the support people set these settings. I used Mint Mobile’s app several days ago when i first inserted the sim card.

Today was the first day i ever saw an APN setting screen. The Ting configuration was the only one in evidence when i opened APN settings. It cant be the correct config. Dish network is our TV provider. I’ve seen their network device in my home router’s devices, but do not do anything with it.

The two T-mobile options only appear after i selected “restore defaults” out of frustration, after Mint’s suggested settings would not save. Choosing t-mobile works in that i can make and receive calls and texts and use data.

Id just like to get rid of the Ting option now, so my phone will stop selecting it at startup.

Phone is a teracube 2e running android 11.

I don’t want to take my own thread on too much of a tangent, but i found a thread on another board that advised users to leave the “MNC” value at the default of 240 instead of 260 as Mint advises. This does allow the user to save the APN settings. I’ll have to test to ensure this allows calls, etc. I’m working a late shift now, don’t want to wake anyone.

the sim card you put into your device has a mcc/mnc pair - a APN profile saved by the user that don’t fit the sim cards values won’t be used

1 Like

That part turned out to be true. Last year when I put Mint on my mata I had a time getting the SIM squared away. MNC is 240.

Here’s my APN on that /e/ device.

Talk about having a hard time. I was on another device reading this forum and wanted to send the screenshots from the mata to that phone. For some reason I am not able to send the pics via Messages. Even stranger not even via Linphone. Yet I can receive images in both. Ugh.

1 Like

With a bit of further testing, I consider this solved. Take Mint Mobile’s APN settings with a grain of salt. Phone and OS are working well for me now. I am new to Android, as well as FOSS and degoogled stuff. I appreciate everyone’s input.