Strava and other map dependent apps don't work with microG

It seems microG can’t handle some map dependent apps, like Zoomy (Uber like) and Strava – it opens, but show the following message when trying to open a map:

On the other hand Google Maps works nice, including the logging in feature. :slight_smile:

There are a lot of APS which doesn’t work without original Google play services.

I don’t know the apps you are talking about. So I don’t know if MAPS from f-droid will help you. But you can give it a try

Thanks! But it seems the issue is related to Google Play Services API, not Maps app. I tried F-Droid Maps anyway, but it didn’t fix my issue as I was expecting.

mhm, I don’t think so, because on my xiaomi capricron and natrium the gps routing and following is working fine.
I think you should create a issue on the issue log site.


Did you find how to use Strava without Google Maps ?
When I start strava I have this message

“Strava will not work without Google Maps.”



@Houvi, to use Strava you have to install Google Maps; there’s no way out. However, the issue here is not having to install GM, but that even by doing that Strava won’t show interactive maps (just snapshots on your timeline), and that’s because Strava relies on some Google Play API methods that microG doesn’t provide at the moment.

My solution? Switch back to the original ROM :frowning:

I’ve just tried the most recent ROM and it seems MicroG has been updated so that Strava now is working 100% :slight_smile:

Unfortunately battery still drains pretty fast.

Oh nice, I use strava a lot and it’s really annoying that the app doesn’t work…
What’s your phone and /e/ version ?

I tested on an old Moto G 4G, and I believe this is not related to the phone, but to MicroG update, so chances are that regardless of your phone Strava is going to work now :slight_smile:

Still won’t launch for me without Google Maps “This app won’t run without Google Maps, which is missing from your device”

1 Like

Yeah, that’s expected. The thing is: in the past it wasn’t working even with Maps installed.

Can anybody explain exactly why Strava really needs Google maps? On an iPhone I believe Strava works with Apple maps (or whatever it may be called), and Google maps is not needed - at least it used to be like this.

F-droid maps was suggested as a possible alternative, but when I search in f-droid I am not sure of what app is meant. Can anybody be more specific?

I don’t use Strava for activity recording, I use a garmin watch to record my activities. I like to use Strava for the social connection with friends all over the world though.

Thanks for reading!

Interesting (to me at least) is that on my tablet with LineageOS the message is slightly different, although it is exactly the same version of strava on my phone and tablet - downloaded through Aurora today.

On both my /e/ fairphone and my lineageOS tablet, microG services Core and microG Services Framework Proxy are installed.

About the same app, I have another issue. Even with Google Maps installed, my device (GS 290 with /e/OS 0.15) can’t go further than the identification screen (log in) ! Did someone already see that ?

Would using RunnerUp on F-Droid work as good intermediary? it claims it an upload to Strava =)

@jimmy3294 Yes same issue on my device (FP3+ with /e/OS 0.15) :confused:
@athair_birb I didn’t try RunnerUp, they indeed claim to have one click upload to Strava, it’s worth a try. What I was doing was to upload a gpx file exported from OpenTracks using the Strava Website. (a bit longer though)

Thanks for this alternative, if ever we can’t use Strava app.

It is not the problem uploading your runs on strava, but to stay in contact with other runners to have tge strava app on your phone. I now stay in contact through a website link on the home screen. Not ideal!

Fixed with e/OS 0.17 update !

1 Like

Aaah cool, thanx for mentioning!!