Sync tasks does not work

I Have created ~20 tasks on my account online using the website. I have then turned on the sync on my phone as described here with the hope to have the tasks on synced on my phone. Nothing happened, neither on the web interface of my account, nor on my phone.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

As far as I know tasks do not work at all since at least one year and half.

But I could be wrong and the above could be an overstating.

I solved the problem installing dav5x from fdroid.

Good luck

Tasks sync works for me with no problem, without installing DAVx5

Yes, I know @petefoth. In fact I wrote that I could overstate. However, sparsely on the forum some users complain about tasks. Some time ago I also see some reports on gitlab about tasks not working as expected on DAV. I’m on a Samsung s8, dev rom 0.20 android 9.

This is not helping me that mich to be honest.i See some DAV5 access, although I did not install fdroid. Should I open a bug somewhere?

Sorry if I’ve nit been helpful. Tasks seems to be working for most people on most devices. It is tested with each new release and the only open issue I could find was #3012 Unable to sync Tasks with any Nextcloud, which is pretty old, and the reporter did not have an /e/ account configured.

So yes, I suggest you open an issue on the /e/ gitlab

Ah, ok. Maybe I will simply add a comment to that issue, thanks for pointing me that out.

Presumably the tasks you created on website are now listed under “Personal” in the tasks interface, so that should work.

Try on your phone clsoing the Tasks app then going to Settings > Apps & Notifications > Tasks > Storage & cache . Select “Clear storage”.

Open Tasks app again. Then force a sync like you did before in Settings > Accounts > etc You should get a new addition in the tasks app entitled “Personal”, with your address included.

1 Like

I have just tried.after triggering the sync the “Personal” row reappears but the tasks are still 0.I am on the last release of the OS and on gigaset GS290.

I’m not that good with this stuff, I was just trying to help by running through the steps on my phone which is Essential PH-1 on 0.20-q. So the fact that you have Personal show up on the Tasks app indicates a connection is made, but what’s happened to the tasks you created on PC or webpage? There doesn’t seem to be much in the way of controls on the web interface beyond logging out and in again or refreshing the webpage, but have you tried? Does adding a new task while everything is setup to sync on the phone do anything? Apart from that I can’t think of anything

Thanks. I have tried to add a task from the phone to see what happens in the website. Nothing. I have tried to log in and log put, nothing again. Tasks are broken, I have added a comment to the gitlab issue, no answer for now. Let’s see.

Update! I have triggered a new sync from my account on the phone, turning off and then on again the sync of the task. And I finally get at least a notification. Personal Http Server error 403 forbidden.
It looks like I am not allowed to upload tasks to my account :tired_face:

I was able to test Tasks successfully recently, but have had problems in the past!

First thing, I had problems with Calendar. It seems to me that Tasks and Calendar work hand in hand to some extent. So I ask in preparation, does Calendar work for you as expected?

Yes, the calendar works. I can edit my calendar from my phone and from the website.

The 403 error I think is the key. Clicking on the details, i can see that it comes from “Authority: foundation.e.tasks” The error is “iCalendar objects must at least have a component of type VEVENT”

This, by the way, it is not a message that I expect from a 403 http status ( 403 Forbidden - HTTP | MDN )

The error is “iCalendar objects must at least have a component of type VEVENT”

I think you are pointing to this being the Tasks error?

In which case it would be good if you could clear the Tasks database on eCloud.

I think that those 403 messages are related to the task app that can not sync. The app make the request but it fails.
I have added ~30 tasks on my todo list, and it took me quite some time to order them by priority. I receive constantly 2 notification, a 501 error message and a 403 error message. I do not think that deleting all the tasks will bring me somewhere, instead, I would like to know why a 403 i receive a message that says “unauthorized” for a resource that theoretically belongs to me.

Is there any technical assistance except the forum? I appreciate all the help that I have received until now, but the error message is really detailed(but it contains private information) and it is probably addressed to the developers, otherwise I can not explain why there is the possibility to receive a detailed log.

I am sorry to be blunt but I think you have been resisting the help already offered :slight_smile:

You are correct that the error is informative.

May I be further pedantic. I think your interpretation of the “website” may be flawed.

In an ideal world you might add a few tasks and events to your device. When the device syncs, the database on your device is copied to a similar database on the cloud. Where you are correct to say you have ownership.

Now you should be able to access the cloud from any device and see the Calendar and Tasks displayed. You should be able to add another item. It should be transferred to the database on the cloud.

Next time the device and cloud sync, we expect both views to be identical. Any sync that sends an error implies an inability to achieve sync. (Remember sync = perfect. No errors are permitted.)

Once I have a sync fail, I assume that I must do or delete something until I can achieve sync again.

Reading what you have reported, my feeling is that in some way you have created a contaminated database at the cloud end. It might possibly have occurred in Calendar.

However, a process of careful housekeeping may resolve it fairly painlessly.

PS I get the bit about personal info in the logs! Further support email address is given here: Getting Started on /e/

Did you search the error:
iCalendar objects must at least have a component of type VEVENT

There is a lot of info out there to describe the significance of VEVENT of which I was previously unaware! I just pick this (not fully related) answer as it tends to support my imagined start of the issue: Error when creating a calendar object: "A calendar object on a CalDAV server may only have components with the same UID" · Issue #1264 · sabre-io/dav · GitHub

Thanks for your reply, I appreciate it. It’s not that I am refusing the help, it is that I am a bit skeptic about to solve an issue “deleting things”. I have been working with software for almost 20 years, and I do see flaws about how users feedback is handled in eOS. Honestly, I support this initiative with all my hearth, but the onboarding experience has been terrible, with a lot of things that didn’t work.
I know pretty well how websites works, from both frontend and backend side :wink: You have described an ideal use case where sync is on and tasks are inserted from the phone. I have added my tasks from the web interface on ecloud, the sync was off(it was off because I have turned it off when I have received the phone). After the tasks where added, I have turned the tasks sync on on my phone, and this lead to the situation where I am now.
From a developer perspective, this thing should still work. I turned on the sync on my phone, the sync process notices that the db on ecloud is newer than that one on my phone, and it download it. To me is clear that this is not working and this should be marked as bug. Anyhow, I want to solve my issue, I have followed your suggestion and I have deleted all my tasks from the web interface. It now shows only one list called Tasks, and when I delete it, it gets automatically recreated it.
The result? you can guess. On my phone i turn on the sync and I get a 403 notification error. I think that the last thing I can do is to write to at
The calendar works good, I can insert event from the web interface or from the phone and I have both in sync.

Thanks for your objective reply. So deleting the tasks, appears not to have had exactly the same effect as deleting the database! (Not ideal, but I can anticipate that would happen here.)

I have tested that when I go to Apps and notifications > Tasks > Storage, with a nicely running Calendar, I can safely delete Data and cache. Then at the next sync, (typically up to 30 minutes, sometimes x2!) what I call “the database on the device” is refreshed “I assume clean”.

I have yet to find how to flush the cloud (selectively) in the same way. Perhaps someone else will provide a clue.

One would imagine that the support team could generate a “Fresh start” for you, but I think it should be controllable by an expert from the device.

In my simplistic view of the error you describe, seems to be explainable by the link I posted, snipping,

Exports often have more than 1 event, so the server will reject this.

Later, @edapx I just checked the support topics and noticed this page. Here it says that a new Calendar created online is not automatically available on the device. The necessary steps are described. I just wondered if a similar thing would apply to a set of tasks?