Synchronisation error for contactsinteraction--recent

Since yesterday I get regular synchronization errors for the account

I’ve tried to share a folder of my eCloud account with another Nextcloud account.
The Federated-Cloud-ID of this Nextcloud account was added to the “recently added“ address book in Contacts.

This entry cannot be deleted (even after removing the share option to this account).

As a workaround I’ve tried to deactivate synchronization for “Recently added”. However this did only work when I deactivated “Recently added” in the “Account extra settings”.

Is it possible to remove the Federated-Cloud-ID from the recently added contacts?

Or is there another way to solve the synchronization error?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

what if you delete the recently-added addressbook within the ecloud/nextcloud contacts? (lower left settings → 3-dot menu → delete). I never used the recent addressbook myself.

Thanks for the reply.

I’ve tried this as well. When I click on delete I get an error message that deletion of this addressbook didn’t succeed.

It seems that that this addressbook is automatically created by the cloud software and cannot be deleted by the user.

However, as long as there are no drawbacks from excluding this addressbook from synchronization the workaround I described in my first post works fine for me (although it is not very intuitive to find).

(you’re right, it can’t be deleted)

the recently-used Address book is provided via Raw z-app-generated--contactsinteraction--recent URI visible to user · Issue #2187 · nextcloud/contacts · GitHub → disabling the plugin will remove the addressbook

if you run your own nextcloud

./occ app:disable contactsinteraction