Telegram FOSS: how to sign up?

I’m trying to install Telegram on /e/ os. FOSS version “can’t be the app for first time sign up”. Well, let’s install original version. Not in AppLounge. Tried PWM version: “We send you the code on Telegram on your other device” (I’ve got no other device and no previous Telegram account). Ok, in a post on this forum: “install Aurora Store”. Did that, and installed Telegram from there. Same message. On another post: install Telegram from I did that, then it worked and Telegram was active. But I’m obstinate and I want to use FOSS version, moreover /e/ seems to recommend it and doesn’t allow the original by default. “we send you the key on telegram”.
So please tell me how, I feel like stuck in a space-time loop.

Well, if you have a working Telegram version with APK and at the same time install Telegram FOSS you can receive your code for FOSS on the working Telegram app. Once connected on FOSS you can uninstall the APK one. No?

Thank you but no:
-if FOSS is installed, apk won’t install (“app not installed” after install process)
-if apk is installed, FOSS is marked as installed in appLounge

1 Like

Take FOSS from F-Droid, don’t use App Lounge I had some issues as well with it regarding Telegram. And make sure the apk is the regular Telegram, not the FOSS. Then both should coexist.

1 Like

The problem also on my phone is that if standard Telegram is installed, fdroid thinks that installing telegram foss is downgrading the non foss app and will not do anything. They must somehow have the same name as far as the os is concerned. But the foss app has a lower version number.
Strangely i had the issue even when using a work profile through the shelter app.

I have the two apps coexisting, the package name of the “normal” app is com.telegram.messenger.web and the FOSS one is com.telegram.messenger. So no possible confusion on names.

Issue still the same for me. Only standard telegram is installed.
If i go to fdroid and search for telegram foss, i get options to uninstall or open.