The attempt of a FOSS etc. / e-W.I.P. by trefix


Using /e/ as daily since 2019.12.06 (first -unofficial- I found for my Moto E 2015) I’m now using e-GSI with a Samsung A3 2017.
“No gg no cloud” & specific working use…’ provider, 2€, 2h, 50Mo /month.

Install: always clean, adb sideload, reboot, locales fr-fr, skip/deny all others first-config. Then install TrackerControl from SD card (+ system apps setting), set clean DNS, install F-Droid.apk, enable WiFi.


  • Openlauncher (I really tried a lot of time but can’t use Bliss)
  • OpenBoard (amoled dark, better language change)

e.stocks apps (de-googled):
Sim Tool Kit

e.removed apps (adb shell pm uninstall --user 0):
Android Keyboard > OpenBoard
Apps > F-Droid (pure FOSS, no bug, updated apps)
Bliss Launcher > OpenLauncher
Calendar > Simple Calendar (local only)
Gallery > Simple Gallery Pro (cause File use)
LibreOffice Viewer > … (no cloud!)
Message > Silence (backup, familly and friends users)
MagicEarth > Organic Maps (offline)
Music > Music Player GO (File and play use)
Notes > Retro Text (local only)
Pdf Viewer Plus > Cuprum Pdf (foss & kiss)
Tasks > … pencil :smiley: (no cloud!)

More FOSS apps (F-Droid):

  • Cythara, DVD (youtube-dl), ImagePipe, Metronome, MineSweeper, MultiSMS, OpenFlood, Solitarie CG,
  • Shelter

sheltered apps:
always enabled

  • TrackerControl
  • OpenBoard

‘always’ frozen

  • Aurora
  • Banque Populaire
  • Contacts (W.A. only)
  • Messenger Lite (télétravail)
  • WhatsApp (familly and a few friens)

local files with micro SD card, USB wire, Debian PC…



Nice work, thanks for sharing ! :smiley_cat:

What would interest me in the course
In terms of shelter:
Is it possible to run TC or Blokada in both profiles?
Both in the private and in the work profile?

Or do they compete with each other?

I didn’t try to use Blokada. For Tracker Control I fisrt install and config in main, then clone into Shelter and config again.

Never seen problem even with different settings in main/pro. Just keep in mind that TC doesn’t support to be frozen in Shelter.

OK, I will try it with TC.
Blokada doesn’t work. Tried it, but no success. It will close immidetly when Blokada is already runnning in main

Blokada in Main an TC in Work are working in harmony…


Dirty flash for v1.0, little issues with OrganicMap and sheltered apps, no time to spend now so I disabled advancedprivacy.

Will test… later! now I need a full fonctionnal device.

Nota : after reboot, OrganicMaps settings were changed (maps location), so I think advancedprivacy had change them at first boot :flushed: :flushed: :flushed:

Will test further with a clean install… in week #28