The mail server responded: 5.7.1 Sender address rejected: not owned by user


I created additional identities but when trying to send an email with this identity, getting the error:
The mail server responded: 5.7.1 <"New identity email address> Sender address rejected: not owned by user " address
The new identity is well define in but when sending with Postbox getting this error…

Thanks in advance for your help


could you pls share a screenshot where/how do you have added a new account under apps ??

@matsch : can you login here with any additional identity ?

whom do you ask and for what it is used ??

Sorry @harvey186, this message was for @matsch (used the wrong “reply” button …).
I have no idea what could be an “additional identity”, but I know enough Postfix to recognize his messages :wink:
So, in this case we may have an Nextcloud (maybe RainLoop ?) account without email account (Postfix mailbox).
That’s why I think the Postfix Admin is useful : to verify the email account against Postfix, not Nextcloud.

1 Like

Just checked : the purpose of RainLoop identities (in RainLoop settings) is to provide a merged view (and “from” when writing/replying) with existing accounts.
So @matsch, if you want multiple identities you’ll have to create them first (it’s free anyway :wink: ).

But I can’t image that this will work, because the railoop is full integrated in the ecloud setup with domain. The railoop IMAP / SMTP server setup will get his information from login data.

but … that’s all theoretical because I don’t know the edrive setup in detail

For the “main” identity, yes.
But in RainLoop you can also add other identities, as a facility to write email from them.
However this identities are not managed by /e/ Cloud, so RainLoop can’t manage logins or accounts.
As an exemple :

So I think it cannot work in /e/, as users have no access to Postfix aliases (for addresses) and Postfix is secured to forbid sending emails from another account. (ie sending as when logged on as

So, as I can see in my own hosted /e/ Cloud, this “identities” feature should be disabled, unless the /e/ server configuration is specific on this subject (I guess it isn’t :wink: ).

When writing :

I was wrong, even if it is a /e/ account I think it will not work (identity spoofing protection at Postfix level).
Sorry for that, I should have checked Postfix configuration more carefully …

@Manoj : could an /e/ Cloud administrator confirm ?

As required have passed the query to the /e/cloud admin to respond.

@smu44 is correct with his/her last post

I was not aware of the identity feature but it should be disabled on

Would someone be so kind to open up a issue on accordingly?

Thanks everyone !

Done :slight_smile:
Please let me know if it needs more details.

[off topic] : I’m a man, and don’t plan to change :wink:


Thanks man (:grin:)!
[Nick2gender() is often a throwing an exception so I got careful using it…:wink:]

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.