TomTom Go app on /e/OS

Is anyone here able to get the TomTom GO app running on /e/OS (FP5, 2.0-t-stable)?

When I start the app it displays an error and closes after hitting the Ok button.

I looked at a logcat of tomtom-go a longer time ago, I’d guess it’s still the same issue due to the Billing API -

Thanks for sharing. would be grate if this somehow be implemented into microG.

Also Disney Plus for example do not work, can’t play any video. Can this also be related to some missing implementation in microG?

app incompatibility should be checked case-by-case. For video I’d rather guess it to be DRM related.

Did you notice the tomtomgo version 3.4.7. workaround by one user (had a subscription though)?

Edit: I clicked around microg settings in an /e/ v2.0 (system → microg → play store services) for another purpose and saw there is a switch to “Handle billing requests”… can you try this (or did already?). Probably only do this when connected to a Google Account of your own, not an anon account.

This feature is experimental and may lead to loss of money


Thank for pointing out this new option. I tried it, and it did get me a step further. But it does not recognize my subscription, and I can’t sign-up for a trail or buy a new one (screen become out of scope, but no message).

I tried same with the 3.4.7 version, but same result. Any other options that I can try?

though they’ll very likely reply with “we only support Google Android” - you never know. Write TomTom if they have any way to accommodate your needs, paying customers have more say than “free users”.

I already wrote TomTom support a few months a go, but never received any response.