Trouble with eCloud

hi, /e/-users and contributors !

after using Firefox-OS since 2015, I have discovered /e/-OS, on a pre-installed GS290.
I agree the principle to have a minimum of essential applications, it’s fine !

I noticed that “Notes” cannot function without a NextCloud, so I got an /e/-account in But then I have encountered 3 problems in cascade :

-1- the day after a message “/e/ Drive has used more data than usual”, without any corresponding amount of data in my /e/-account or in the phone. I had the e-OS-0.22 update.

This is already mentionned in some posts of the community and gitlab, but not explained nor solved, only turnarounds, apart that the e-OS-0.23 update could solve it; I applied this update, and tried to configure the phone so to master or limit the “data-leak”; finally I deleted my /e/-account in the accounts-parameters of the phone.

-2- reading more posts here, and finding more informations in the e-gitlab,
I tried again to add my /e/-account on the phone ( is accessible from my PC). But then : “Neither a CalDAV- nor a CardDAV-service was found”; (I use only the local-agenda of the phone); this is mentionned in some community-posts too; I try to apply the turnarounds, try to reconfigure some parameters in the huge menu-tree, and then :

-3- next tentative to add my account, I have : “check your internet connexion” ; I don’t understand because I can still access to internet through the browser. This is also documented in some posts.

Finally, I decided to suppress completely my /e/-account on

My question is : where is the problem ? 3 hypotheses :
-A- an issue ? for instance too much activity at the time of my tests;
-B- a too narrow bandwith of internet between France and Finland ? (sometimes the browser told me Url or Https of /e/ inaccessible).
-C- some bad or hidden options in the phone, due to my hazardous trials, so that it would be wise to reinitialise completely my phone under /e/-OS ?

As I am new to this /e/-OS-phone, and will have soon a larger-data capacity at my 4G-provider, I have still many things to master. Apart from the problems cited here, I find the /e/-OS-solution awesome and unexpected, after Firefox-OS was abandonned by Mozilla.

Thank you for your attention to this post;


Option D :smiley: : eDrive failures. Good news, it is currently reworked : Week 16, 2022 : Development and Testing Updates. You can follow some enhancements here : Commits · v1-oreo · e / os / eDrive · GitLab

hi, @smu44, thank-you very much for the “option D” :wink:
this is exactly what I was looking around ! As /e/-OS is quite new (0.xx), it seems normal that certain parts of it are reworked. Really, it’s a chance that developpers have decided to perpetuate Cyanogenmod / LineageOS upon AOSP.


hi, @smu44 and /e/-users,

about the question of not-offline-Notes, I found on this forum some turnarounds :

  • use mail-drafts : effective !
  • get an offline-editor with Apps : I installed Editor (billthefarmer), one of the leanest, but there is also Simple-Text-Editor, Notally, LesserPad, lite and recents too.

In some gitlab-backlog-issues the question of an offline-Notes has been raised, but it seems complex to modify Notes properly for that.

So, waiting for a consolidated /e/-drive, I am glad to dispose of Notes -and- Editor :wink: . No more “trouble” for me, as I see that things are taken in consideration, many thanks !

1 Like