Truble installing e os on s9

Hello !
I’ve been using e os on a samsung s9 for several years with no problem. My phone has broken so I buy a new S9 in order to be able to reinstall e os
I’m using easy installer as I am not a pro in this things
And I find a problem : when getting to ODIN page -download - in stead of having E, I go back to android.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

hi @Lola,
welcome to this Forum.

are you sure it is a SM-G960F and not a SM-G960U ?

1 Like

Hello @piero
Yes ! It’s an S

Hold and release the Keys is an “ART”

it could be otherthing than the little bue line on your device


I think I had the same problem installing on my S9 with the easy installer (which I recommend to use!). When it should boot into e recovering, it booted in default and that did not work, because the system was erased.
I just repeated the whole workflow and paid attention at the moment where you push power, volume up and pixby button and then the contrary.
Hope this helps.
Now its working perfecty on S9.
So Piero is right with rhe crutial step!

OK, i’ll give it a try this afternoon and tell you
Thanks @piero and @Mobi1

Hi, thank you for posting this procedure. I tried it on my Galaxy S9. Several attempts failed. I always seem to end up in the Galaxy recovery instead of the e-recovery.

Do you have any advice, please?

When the problem is: recovery seemed to flash to the phone without error, but on attempting to boot to Recovery, all you can get is Android recovery …

then @piero’s “crucial step” is the most likely cause, just as reworded by @Mobi1. I had exactly this problem and my wording of the issue is Your first boot into TWRP.

Thank you so much. Tried this procedure. Both descriptions. Watched the video. Still Android :thinking:
My phone is a SM-G960F.

Thank you. Found this:

How to unlock

  1. As i personally did, and other users reported, if you face any of the things above, flash latest full stock fw of your country with Odin, boot up, dont reboot, dont unplug the sim and don`t disconnect the network connection for 7 full days (168h) . It seems that after 7 days of uptime, RMM state resets and you can flash TWRP again without issues. You can see uptime in settings/about device/status.
  2. Some users reported this guide was working in first Oreo fw releases, can’t guarantee it still works.

Could you kindly explain for a non expert what this actually means and how I can do the right thing? I am new to this. But I am determined to get rid of my android OS.

Thank you.

Maybe I am a bit disoriented. What about this:


  • Download TWRP_*.img, push it into phone storage, choose install image in your current recovery, navigate to downloaded *.img file, select it, select to flash as recovery.

After booting in TWRP download and flash no-verity-opt-encrypt-6.1 zip to disable data partition encryption
If for any reason you fail to install TWRP multiple times/different methods, make sure you check this thread

Question: How can I select the .img file to flash as recovery?

As i understand, this instruction is for replacing TWRP by another TWRP version.

Try the latest one. or 3.5, but just not 3.4 version that was buggy