TTS problems on /e/

I have a problem with the (missing) TTS (text to speak) in /e/.
I tried to fill the gap with the installation of espeak and flite from F-Droid. Unfortunately, the installation failed. To be more precise, F-Droid succeeded in downloading and installing in the packages, but activating an actual TTS-engine failed. Since that moment, every time I try to alter the system’s TTS in the preferences, the preferences site for TTS crashes.
So, I removed espeak and Flite from the system and started to search for Googles TTS in the internet and finally found an apk outside Googles play store. I installed it and went tried to reach the TTS preferences, but it crashes, again.
I have no clue what to do, now. Any help appreciated.


There is an issue related to your request :

But no mention of crashes. When I was on /e/ Oreo, I had also crashes with TTS. You could raise an issue with some logs.

1 Like

If you perhaps happen to miss specifically OsmAnd talking to you, it has a built-in workaround …

A nice guy on this german forum made a package for TTS. I installed it on my S7 with LOS 17.1microg and it works fine. I also tried to install it on my second S7 with /e/ but it fails. If I install the package, the settings app crashes (when I want to select which speech output I want). If I uninstall the TTS engine (vocalizer), I can call up this setting, but (of course) I cannot select anything.
Does anyone have an idea, what the reason could be? I use the unoffical pie /e/ build for the S7.

1 Like

Sorry, this was my error. I forgot, that I flashed the rom dirty over the oreo rom. So there was a conflict. After flashing clean, it works.

1 Like

If this is working (incl. more languages) then it might be worth to be shared with the /e/ developers.