Two apps not functioning on /e/

I’m having issues with the app com.cgi.oslomelding.foresatte. It starts and then simply sends me out of the app. Same issue with com.ogsdroid after logging in.

If you see an error message saying “The app keeps on stopping”, then that can sometimes be fixed by uninstalling then reinstalling.

1 Like

The F-Droid page for OGS (com.ogsdroid) says "The app is still early in development
so be prepared for bugs and half-implemented features." and the latest update there is from August 2017.

Aurora Store (alternative access to free-of-charge Google Play Store Apps) lists “Skolemelding foresatte” (com.cgi.oslomelding.foresatte) as GSF-dependent, which means it needs Google services.

/e/ has no Google services. /e/ uses microG to mimic Google services as good as it can, but that has its limits.
While it works for a lot of Apps, there is no guarantee, and even if it works at a particular time, changes on Google’s side can break that at any given time, until microG did the necessary catching up again.

The App currently isn’t listed as not working here … Editable List of Apps that work or do not work with microG … or here … … so your problem with it now might still be something else.

In short: There’s always a possibility stuff just doesn’t work.

Some generic things to try …

  • Reboot the phone (Does it work again?)

  • Settings - Apps & notifications - (select the App) - Force stop (Does it work again?)

  • Settings - Apps & notifications - (select the App) - Storage & cache - Clear cache (Does it work again?)

  • What does it say in Settings - About phone - Android version (<- tap on this) - /e/ version?
    Did you get a notification that an OS update is available?

  • Settings - Apps & notifications - (select the App) - Storage & cache - Clear storage (Warning! This will delete all data the App saved on the phone. Does it work again?)

  • Uninstall and reinstall the App (Warning! This will delete all data the App saved on the phone. Does it work again?)


Thanks for the detailed reply, I’ve tried many of these solutions, but will try the others too, just to be sure.

Tried the “Skolemelding” app. A splash logo shows and then it quits. No messages.
Recorded logs are not as straightforward as I had hoped. More warnings and debug messages than errors. Only errors are regarding channels…

Channel is unrecoverably broken and will be disposed!

The app uses Firebase services which I believe microG still does not support or support fully (citation needed).
On a Google-based ROM the Skolemelding app works fine so I think that’s it.

Regarding OGS, the app is clearly not maintained. Produces a HTTP 500 error which is generic. As mentioned the app hasn’t been updated since 2017. In fact there is only one issue opened since 2017 on their github. It’s from March 2020 concerning the login problem. No responses.
Might as well uninstall it as it is unusable.

Checked the Online Go forums. The dev had a thread there but no activity since 2019.

Just using a browser should suffice. Create a shortcut to the site or use apps like WebApps or Native Alpha.

1 Like

Thanks for the detailed response! :slight_smile: