TWRP flashing fails



I tried to install the eOS on my Xiaomi Mi 9t (davinci), but I failed at installing the recovery image.
(The bootloader is unlocked)

After installation, the phone doesn’t boot. I reflashed original recovery.img and phone booted again.

I tried different recovery images provided but with the same effect.

The current OS installed on the phone is MIUI 12.1.4 Global

No idea how to continue.

The latest /e/OS ROM I find at is which is an Android 10 (Q) build (naming convention).

As far as I can tell MIUI 12.1.4 Global is Android 11 (R).

The install instructions say, towards the start

It is important that you know that downgrading Smartphones on OS versions greater than the /e/OS OS version you plan to install, can cause instability or at worst brick some devices. We recommend that you check your current OS version, before attempting the installation.

I am sorry to say that you would need to downgrade the Xiaomi firmware to the latest Android 10, in order to install this ROM.

1 Like

So I assume it’s the same case with recovery image?

I tried also to flash regular TWRP (for this phone) and it didn’t work.

My expectation, if you flash the correct TWRP onto a phone, it will now only boot into TWRP, that is Recovery mode, or Fastboot mode.

It probably will not boot into the “original” system.

funny thing because I did that, fastboot says flash done and I reboot to recovery using a command line and stock system boots. After that, with key combo, the stock recovery is still there.

… but the method advised for this phone is

fastboot flash recovery recoveryfilename.img
Now reboot into recovery to verify the installation:

  • With the device powered off
  • hold Volume Up + Power.Keep holding both buttons until the “MI” logo appears on the screen, then release.
1 Like

you are right, my bad, I did it wrong manually too before, now it works

Next issue is that after installing the e/OS camera doesn’t work (the app hangs on black screen).

So I think I need to reflash to Android 10 and then to e/OS. I will let you know if I succeed.

restoring to stock ROM using:

Dropping for now, I went with other custom ROM with Android 13 and everything works.

Thanks for the help.

Have you tried switching between face and rear camera ?
it resolved the problem on my device.

This topic was automatically closed after 180 days. New replies are no longer allowed.