Unable to install TWRP on Samsung Galaxy S5 G900V (verizon) eMMC CID 11

I have been trying to get /e/ installed on my S5 following the /e/ installation instructions.
I have successfully unlocked the bootloader and have rooted my S5, (no easy task on the 11)
When I try to install TWRP the installation fails with the following errors.
(I am using Ubuntu 19.10)
Any suggestions would be greatly appreciated.
Cheers
Bevan

$ heimdall flash --RECOVERY twrp-3.3.1-0-klte.img --no-reboot

Heimdall v1.4.2

Copyright © 2010-2017 Benjamin Dobell, Glass Echidna

http://www.glassechidna.com.au/

This software is provided free of charge. Copying and redistribution is

encouraged.

If you appreciate this software and you would like to support future

development please consider donating:

http://www.glassechidna.com.au/donate/

Initialising connection…

Detecting device…

Claiming interface…

Setting up interface…

Initialising protocol…

Protocol initialisation successful.

Beginning session…

Some devices may take up to 2 minutes to respond.

Please be patient!

Session begun.

Downloading device’s PIT file…

PIT file download successful.

Uploading RECOVERY

100%

ERROR: Failed to confirm end of file transfer sequence!

ERROR: RECOVERY upload failed!

Ending session…

Releasing device interface…

On the phone the error messages in Download are :

Odin mode

Product name: SM G900V

Current binary: custom

System status: custom

Reactivation lock(kk): off

Qualcomm secure boot: Enable (csb)

AP Swev: S1, T2, A1, A2, P1

Secure download: enable

UDC Start

Secure check fail: recovery

1 Like

Hi @Miraceti

I have tried to flash /e/ on my Galaxy J5 using ubuntu 18.04, but Heimdall wasn’t getting the job done. In the end I got the job done using Odin on a windows machine.

However, since you have mentioned you have rooted your device and you have issues installing TWRP, maybe you can get some results with instructions from the TWRP website (link below). Just take care you pick the right device.

Good Luck!
:four_leaf_clover:

https://twrp.me/Devices/Samsung/

Hi Renax,
Thanks for the suggestion, unfortunately it didn’t help. All of the various attempts to get /e/ installed on the S5 have failed, so I think the best way will be to wait until /e/ phones are available in Australia.

Thanks again

It’s a long shot, but I remember reading reports where sudo ‘fixed’ a Heimdall error.

Hi Reb77,

Thanks for the idea but I tried that and unfortunately it didn’t work.

The installation of TWRP for klte and /e/ for klte dev (Pie) on a Samsung Galaxy S5 LTE - “klte” SM-G900F was uncomplicated for me. The device also did not need to be rooted.

But with devices from AT&T and Verizon the bootloader is very often locked or it can only be unlocked with considerable effort. You have succeeded.

Since Ubuntu 19.10 and Heimdall v1.4.2 don’t give you the desired success, I recommend you to try installing TWRP for klte with Samsungs Odin3 on a Wind°ws PC. Even if it’s not comforting, but many users have problems with Linux & Heimdall. Read more …

Hi Archje,
Thanks for the suggestion and I’ll certainly give it a try when I can get my hands on a windows pc.

Cheers

@Miraceti, another idea: Since your SM-G900V is rooted, the → Official TWRP app should allow you to install TWRP for klte -3.3.1-0. Suck it and see, right?

See also → “This app can run without root, but most features will not be available without root.” and “How do I use the app?”

because of ideological reasons, I also had in mind to flash my device with Ubuntu. However, when I was running Heimdall on my Ubuntu-laptop I got all these error messages on my screen which where not entirely congruent with the image of reality which I had in mind. So then I went to The Duck, spending days (I lost track of time; it could have been weeks) to see if I could find ways to get Heimdall working on my Ubuntu system, because I thought I was doing something wrong. And to my shocking surprise I found this one guy telling on some forum that Heimdall is not meant to be working on a Ubuntu system.

Now I am really not a technician, so I am really not able to tell if this guy is telling the truth, but when I consider that Heimdall & Odin are programs developed by Samsung exclusively for Samsung devices, then it would make a lot of sense to develop these programs to be properly working, at least on a Windows machine.

So then I had to ask myself the question how much I was willing to hold on to my ideology, and how much time I was willing to spent to find out if I was able to make the miracle of the Ubuntu machine happen…

After some consideration I came to the conclusion that I just wanted /e/ on my device, up & running, and if it was really important to me, I always could find out how to get Heimdall working on Ubuntu, afterwards. And when I finally made up my mind, I was happy I still had one desktop in my household, which has W10.

And when I followed the steps explained by @Anonyme, the job was finally done within minutes. After trying all this difficult stuff, this was peanuts.

Now I am running /e/ on my device almost a week! :smiley:
I have to admit /e/ isn’t running as smooth as android, but just the thought of being able to bring a mighty organization made up of thousands of clever engineers and smart businessmen on its knees, makes it all up… :grin:

that’s my story how I got in /e/, in short…

good luck
:four_leaf_clover:

1 Like

@Miraceti, just tried it yourself - it works!

  • Galaxy S5 SM-G900F, StockROM Android 6.0.1, rooted;

  • Official TWRP App > me.twrp.twrpapp-26.apk > installed,

  • then TWRP App > twrp-3.3.1-0-klte.img > "Flash to “Recovery”.

OKAY - Flash Completed Successfully!

Hi Archje,
Sucked it, didn’t see lol. It blew away my recovery, so I have used the app to restore my backup recovery.
A good idea though :slight_smile:

The problem could be the Device I could choose. The only one that even went close was Oacenia, Americas and all I could see of the model was SM ??? The other options models were incorrect.
I’ll give Odin3 a go when I get my hands on a windows box.

Oh yes I saw all of the images and even though it said it was successful, it’s just that it wasn’t.

Is your device an eMMc CID 11 or 15 ?

Have you checked if your SM-G900V has:

  • Reactivation lock [ Tap: Apps > Select Settings > Settings > Security : Reactivation lock ]
  • encrypted partitions, e.g. /data

I had the following choice:

See also:
TWRP for Samsung Galaxy S5 Qualcomm
Download Links:
International, Americas, and Oceanic (SM-G900F, SM-G900W8, SM-G900T, SM-G900M, SM-G900P, SM-G900V, SM-G900I)


My eMMC CID starts with “11” …

Reactivation lock is disabled
USB debugging is enabled
Nothing is encrypted
I choose the same options as you with the exception of the twrp file, I downloaded it and installed it from the sdcard.
Mine is an 11 too.
When I flashed the recovery and it said successful I then powered off the device to get into recovery. Perhaps if I pop the battery out instead of powering off??
I’ll give it a try in the morning, it’s getting late here now.

Thanks for your help and persistence, it’s very much appreciated.

Cheers

Yeah! → Remove the battery for a few seconds

Unfortunately no joy with popping the battery out, though I caught a very quick error message when I go into recovery, it was " No Version" then it popped up the FAIL warning screen.
I am arranging the loan of a win10 laptop on the coming weekend so when it arrives I’ll try the method you sent.
I know that Verizon make it very difficult to unlock the bootloader, perhaps my problem is some baggage related to their efforts to lock the phone down.
Is your phone from Verizon?

Samsung’s Odin3 is easy to use and works effectively. But if the bootloader is blocked in the device, it cannot install TWRP.

I know my Galaxy S5 SM-G900F (Europe version) as a robust and uncomplicated phone. The versions of Samsung Galaxy S5 (USA) SM-G900V (Verizon); G900R4 (US Cellular) and G900P (Sprint) I only know by hearsay. But it is well known that the US carriers protect their terrain and make the devices almost inaccessible.

I keep my fingers crossed that you will find a solution and we can soon welcome you as /e/ user.

I hope so, I’ll keep you posted when I manage to have a go at it through Odin.

Thanks again
Cheers

Hi Archie,

Unfortunately I have had no success with Odin at all, the following errors were reported:
ID:0/005 Removed!!
ID:0/005 Added!!
ID:0/005 Odin engine v(ID:3.1401)…
ID:0/005 File analysis…
ID:0/005 Total Binary size: 9 M
ID:0/005 SetupConnection…
ID:0/005 Initialzation…
ID:0/005 Get PIT for mapping…
ID:0/005 Firmware update start…
ID:0/005 NAND Write Start!!
ID:0/005 SingleDownload.
ID:0/005 recovery.img
ID:0/005 FAIL! (Auth)
ID:0/005
ID:0/005 Complete(Write) operation failed.
All threads completed. (succeed 0 / failed 1)

So I’m all out of options now so I will have to admin defeat and just wait for eOS phones to be available in Australia.

Thanks for you help, I really appreciate your efforts mate :slight_smile: