[UNOFFICIAL BUILD] /e/ r Sony Xperia Z3 Tablet Compact (scorpion, z3tc, z3tcw)

Here are unofficial builds of e-1.11-r for this device

I have run the WiFi version and it seems to work as expected. I dirty flashed it over my unofficial Lineage for microG build (see https://forum.xda-developers.com/t/rom-z3tc-lineageos-18-1-sgp621-unofficial.4256523/post-88466081), and all my installed apps continued to work under /e/OS :slight_smile:

I haven’t run the LTE version at all - you’re on your own :wink:

I described how I managed to install my Lineage for microG build on my z3tc wifi in this xda forum post. I’m pretty sure that steps 3 & 6 aren’t needed: installing with TWRP didn’t work. If you follow steps 7 - 9, you can install any ROM using PBRP.

To boot to recovery press the power key, and once it has vibrated, keep tapping the volume down key until the blue led lights up

I’d be interested to hear how these builds perform, but I can’t offer much support. I suggest subscribing to this XDA forum thread

Good luck

1 Like

Amazing! I own the 621 (LTE) and WILL try, but not it’ll take a few weeks till I have the time. I have PBRP / A11 installed so I assume when I take a NANDroid I’ll be able to go back any time?

I guess so, but I can’t guarantee it

Thank you so much @petefoth, as you know I am a big fan of this device!
Just dirty flashed (wiped dalvic & cache) the build over the last LOS 4microG build from you and it seems to work just fine!

Some first observations:

  • custom color option was gone and just blue was available as in /e/
  • Trebuchet launcher stayed as the main, which is great for me! :slight_smile:
  • GPS works just fine, and always did on my devices (I got several of them in the family)

I wonder which of the builds you will maintain in the future?
Thank you once again,
Max

@MaxO: do you use the 621 with LTE? Does everything work, like phone, internet etc.?

Yes, everything works fine so far! :ok_hand:

Latest unofficial / custom Android 11 / R builds, built from the v1.12.3-stag are available here

I dirty flashed the z3tcw WiFi version over the 1.11-r build with no obvious problems

Sadly, due to my incompetence, this build is signed with public / test keys. I probably wont have time to do another build to fix that, so if that is important to you, then I suggest you don’t update now, and wait until the v1.13 build comes around. Sorry!

Release notes are available here
https://gitlab.e.foundation/e/os/releases/-/releases/v1.12.3-r

Hi Pete!

I finally found the time to start flashing you e/OS-build, but I’m afraid I need a little help here. A few questions:

actually I have Lineage_z3tc-userdebug 11 RQ3A_211001.001 eng.devil.20220212.130725 test keys installed. Unfortunately, with GApps - which I definitely want to get rid off! So I guess a dirty flash here (after wiping dalvik/cache) will surely not do the job. I use PBRP-recovery. What should I delete / format in the first place, and, after that, can I just sideload the ROM? I am aware I will start from scratch, I took backups of all files, apps and media.

Honestly I do not know what “public / test keys” means. My current version seems as “test keys” version as well. What does it mean, what should I be aware of and what does it mean for future upgrades?

Do I need any other files like vendor or boot images?

Do you have any experience which Magisk version works / should work? Without the knowledge rooting is going to work I won’t even start :wink:

Hope to hear, can’t wait to get e/OS/ on this (still) great device!

Thanks in advance!

I’m not sure whether or not flashing the /e/OS ROM will get rid of installed GApps. Safest is to format data partition in PBRP. Then side loading the ROM should be fine

This is to do with how builds are signed: with properly signed ROMs (i.e. ones not signed with these public / test keys which are available for anyon to use) you can be sure of who made the build and - more importantly - only OTA (Over the Air) updates signed with the same keys can be installed by the Updater app. But as I don’t / can’t provide OTA updates, it really doesn;t matter.

No

Sorry - no. I don’t root my phones. Having said that, if rooting with Magisk worked on your currently installed LOS ROM, then it should work on this /e/OS one as well. I have seen threads in this forum about /e/OS users successfully rooting their phones with Magisk, but it’s not something I can give you any help with.

Hi Pete, thanks for your ultraquick reply. Unfortunately in Windows Powershell I get this error as soon as I start the sideload:

PS C:\Android> adb sideload .\e-1.12.3-r-20230621-CUSTOM-z3tc.zip
serving: ‘.\e-1.12.3-r-20230621-CUSTOM-z3tc.zip’ (~0%) adb: failed to read command: No error

On the screen of my tablet in red letters the text “Zip file is corrupt” appears.

I downloaded the ZIP from another mirror just to be sure. But it immediately hangs in sideload at 0,0% and gives this “corrupt” error and aborts. I have already wiped data and cache/dalvik.

:frowning: Any idea what might help me out?

I’m sorry, but I don’t own the z3tc LTE model, only the z3tcw WiFi model. It is possible that the build on AFH is corrupt: when I have some time I will try downloading it and comparing it with my local version. In the mean time, if you need your phone to be working, you could try

Later:

I have downloaded the zip file and checked the MD5 checksum with the built version and the checksums match. Try checking the MD5 checksum of your file using the following command in Powershell
get-filehash -Algorithm MD5 e-1.12.3-r-20230621-CUSTOM-z3tc.zip. The answer should be cda9791160010c974bf250f69bc4000b.

  • If it is not, then your downloaded file is corrupt, and you will need to download it again
  • If the checksum does match, then either there is a problem with the zip I uploaded, or ther is a problem with your adb setup

Have you used adb sideload to flash a different ROM (i.e. LOS, L4M, or the earlier /e/OS image). You could try copying the ROM to an SD card on the tablet, and installing direct from PBRP instead of sideloading

Dear Pete!

Once again thank you for the quick reply.

  • I have checked the checksum and it matches your answer.
  • My ADB setup usually works when installing roms to other phones, I use the same computer for a while
  • Trying to install the ROM directly from SD-card gives the same error (allthough it gives me 5 boxes to tick when I start: [] Zip signature verification (unchecked), [] Reboot after installation is complete (unchecked), [] Enable Dmesg logging after Flash (unchecked), [] Deactivation (Patch DM-Verity) (automatically checked, I didn’t uncheck it) and [] Advance Disable Forced Encryption (unchecked)
  • Do I need to change any of these settings?

In the meanwhile I am downloading the 1.11 file - but I remember for my phone this specific version had a HUUUUGE batterydrain (despite ANY OTHER version). Report later!

Added 2 minutes later: when installing from PBRP it gives immediately the following:

"
Full SELinux is present.
Encryption status : unencrypted
MTP Enabled
Installing zip file ‘/external_sd…z3tc.zip’
Checking for Digest file…
Zip file is corrupt!
Error installing zip file ‘/external_sd…z3tc.zip’
Updating partition details…
…done
Preserving logs…

Would the logs file help you out? I will preserve that file! Just to be sure!

Add on 2: the 1.11-version installed!

When I flash my device, I don’t have the Deactivation (Patch DM-Verity) option checked. Just tried flashing my WiFi device with that and it works fine, so that’s probably not the problem. You could try posting the logs to a paste service like https://pastebin.com/ , or drop them in the Filedrop folder in my /e/ cloud account https://murena.io/s/HxEaFGxafTE3cgB and I’ll have a quick look

If that is still a problem, then it would be worth trying

In fact, it would be a help if you did do that: if there’s a problem with my build setup causing corrpt file problems, then it might have done the same in that version

I tried installing 1.11 - installing worked. Directly flashed Magisk after, but the device did not boot (not even boot animation appeared).

Then I wiped Data again and just installed 1.11 - that worked. After booting to system I got the bootloader (about 2 minutes) and then I was back in recovery. System did not boot.

Sorry - I’m right out of ideas :frowning:

Hi Pete!

So, Version 1.11 and the LOS MicroG can be installed. The /e/OS V1.12 stays corrupt, so something is wrong with the file.

I guess with my first install (and directly flashing Magisk (newer version) something got corrupted in my partition.

Now I need to go back to stock first and then try V1.11 again. In the meantime, if you can fix V1.12 that would be much appreciated!

PS: the LOS version gives a bootloop and after a minute or 2 jumps back to recovery. The /e/ 1.11 does about the same. But at least I could flash them. As said, I think something’s wrong with my boot or partitioning. Can only try again after July 20th since flashling stock is out of my league

If the LOS version is bootlooping, then you need to format the data partition from PBRP before re-installing.

Why would you need to re-install stock? From what I understand, that won’t do anything that can’t be done by flashing a sensible boot image (try the one from here), flashing PBRP recovery, the from PBRP formatting the data partition, then installing the ROM. Unless attempting to flash Magisk has done something unpleasant to your file system which I suppose is possible. LIke I said, I don’t root phones and I don’t know anything about Magisk

I’m sorry but I made the builds on a cloud VM that is long gone. I won’t be making /e/OS builds again until the v1.13 build is released. I will try and find out if anyone else has problems with the v1.12 release before I take it down

Has anyone else tried using this version? If so has it worked for you. @Infinity is having problems with it, and I’m not sure whether the problem is with his phone or with the ROM image.

Any / all feedback welcome - thanks

In the end (after LOS4MicroG and 1.11 installed but bootlooped, with and without Magisk) I ended up formatting System and one other partition too, besides data. Maybe that ruined it even more.

PBRP is still in place and booting, I can also fire ADB commands or install from SD. But whatever I try, just bootloops. Strange.

Then maybe re-installing stock is the way to go after all. The outcome can’t be any worse than what you have now :frowning:

(File that comment under “Famous last words” :slight_smile: )